FORUMS: list search recent posts

Final Cut Pro 7 keyboard shortcuts problem

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Ricardo Guerreiro
Final Cut Pro 7 keyboard shortcuts problem
on Nov 27, 2009 at 10:34:41 am

Hi, I'm running Final Cut Pro 7.0.1 on 10.6.2. I'm from Portugal and I'm using a Portuguese numeric Apple keyboard. This is the same configuration I used on FCP 6 which worked fine. Ever since I bought Final Cut Studio (the newer suite with FCP7) the keyboard shortcuts are not working properly. I have address this problem to Apple care but since no solution has been provided till now, I am wondering if I can get help from other people.

The problem. Every time I launch FCP7, the spacebar and a couple of other keys, are not working as their default shortcut. So for example, loading a sequence to the Canvas or a clip to the Viewer and pressing the spacebar, does nothing. If I open the customise keyboard layout window, I can visually see that the spacebar is not assigned for Play.

One solution. Reset the keyboard layout, sometimes works and after doing that, I see the spacebar as assigned to Play and very other default shortcut works fine. Other times, after reseting, I have to load the default US keyboard layout for the shortcuts to work.

Another solution. Load the default US keyboard layout without opening the customise keyboard layout window. This normally works all the times. Now, I load the default US keyboard layout but due to key differences, I have to press some different keys than people with the US keyboard would; for example `(grave) or M sets a marker on the US keyboard whereas I would have < or M for the same task. But I load the default US layout and every thing is working fine.

The next problem. Now, US default layout loaded and working great. That is, until I quit FCP. When I launch FCP again, I have to go through loading the US layout again. It is not retained when I quit. So every time I launch FCP I have to manually load the default US layout in order for shortcuts to work properly. That's not very cool when you paid 1000€ for your working tool

Another solution (or so I thought). Okay, even if I think this should be working well out of the box and I should not have to worry about going around this problem, I had to think of a solution not to be annoyed every time I have to work. So, I loaded the default US layout, made some changes and added some shortcuts that I like and saved the keyboard layout. Problem solved, I thought. Next time I launched FCP, guess what?! My customised layout was not the one that was set. The one that was set, was the same old faulty layout I've been dealing with rom the beginning. So I thought I was stuck to having to manually load a keyboard layout every time I launch FCP. Well, I read some good parts of the FCP manual. Also read FCP7 - Pro Video Editing (by Weynand, Peachpit Press). I never read anything specific on this but shouldn't the loaded keyboard layout be retained after quitting and relaunching FCP?

So now I'm about to quit solving this. I'm almost accepting the fact that I have to manually load a keyboard layout every time I launch FCP, which is every day. Any ideas or hints on how to solve this?

Thanks.


Return to posts index

Jorge Medeiros
Re: Final Cut Pro 7 problem keyboard shortcuts
on Dec 18, 2009 at 11:06:17 am

Hi, Ricardo

Same problem here. See no better solution than those.News?


Return to posts index

Frank Knipschild
Re: Final Cut Pro 7 keyboard shortcuts problem
on Dec 22, 2009 at 6:06:44 pm

Hi Ricardo,

Just installed the new FCP 7 and encounter the same problem. Some shortcuts are simply not working ! Very annoying i must say. Now wait for the update i guess but what a bad delivery from apple.

Good luck.
Frank

Frank Knipschild
quanvision S.L.


Return to posts index


jean mathis
Re: Final Cut Pro 7 keyboard shortcuts problem
on Mar 4, 2010 at 5:23:38 am

Well I have the same problem here with a french azerty keyboard quite annoying that nobody came up with a solution yet here.
Jean


Return to posts index

Jorge Medeiros
Re: Final Cut Pro 7 keyboard shortcuts problem
on Mar 9, 2010 at 5:17:16 pm

Well, the way we´re using is to switch between languages whenever needed.


Return to posts index

Helder Silva
Re: Final Cut Pro 7 keyboard shortcuts problem
on Apr 25, 2010 at 3:32:33 pm

Is it possible than no one have a solution for this problem? i have the same problem, every time i open final cut a have to chance the space key so the keyboard work fine..but it`s amazing this happens and there is no solution, i guess only the americans have the right to have right keyboard..europeans not! unbelievable. God bless premiere.

more time i work with mac and software apple more a hate it! Mac is so beautiful, don`t crash it, very intuitive..right..i have mac and pc and it`s all the same crap, problems everywhere.

Take care


Return to posts index


Patrick Elliott
Re: Final Cut Pro 7 keyboard shortcuts problem
on Nov 28, 2010 at 8:54:51 pm

I had this problem with FCP 6. I found out it is possible to make some corrections in the keyboard layout (under Tools) and to save them as a personal layout. Now I can select it very easy every time I work in FCP. I know you have this problems in FCP 7 but It would surprise me if this isn't possible anymore in FCP 7. Otherwise sorry for useless info.

I'm really new to AE and have the same problem, any of you have an easy solution here?


Return to posts index

George Lamb
Re: Final Cut Pro 7 keyboard shortcuts problem
on Dec 15, 2010 at 2:04:32 am

Just discovered this thread, as I too have been having similar problems with the keyboard shortcuts: have to reset such things as "command z", to see the whole window of timeline, etc.
Has anyone found a solution to this?
For what it's worth, I'm in the US.
Using FCP v 7.0.3, Mac OS 10.6.f
Thanks
George


Return to posts index

David Denker
Re: Final Cut Pro 7 keyboard shortcuts problem
on Jan 18, 2011 at 7:34:45 pm

Hey guy, ich don't have a great solution but, i just enabled the language icon in the menu bar an aktivated my language (german) and english. When I use FCP I just switch the language, you can switch the language also while FCP is running.
I hope you like that.


Return to posts index


Matthieu Foulet
Re: Final Cut Pro 7 keyboard shortcuts problem
on Feb 8, 2011 at 2:47:44 pm

Hi everyone,
it's getting weirder and weirder...
I have followed David suggestion, the problem is resolved.
After a bunch of tests, it appeared that the only requirement is to enable the U.S. language in the system preferences.
No, you don't need to actually select it, as long as it is enabled and eventually everything will work flawlessly.
The weirdest thing is that you only need to launch FCP once with US language enabled to make it work.
Once you've done it, you can constantly disable it and everything will work fine...
Maybe there has been a misunderstanding between Apple programmers and the FCP company programmers since it seems to be a common bug, but... wait, what ? ;)


Return to posts index

Luc Detours
Re: Final Cut Pro 7 keyboard shortcuts problem
on Apr 15, 2011 at 8:42:58 am

I see this problem on every video french forums.
Apparently, a same solution/process works for some people and does not for other people.

What's working on my MAcBookPro Snow Léo FCP 7 is :
- enable "Français numérique" ("digital French" !!!) in the preference panel/language/méthode de saisie
- choose "Français numérique" in the top bar of the Finder : the little french flag, with "123" beneath it.
-In FCP open the "Tool" tab, then choose "Modèle de clavier par défaut - Français" (Default Keyboard layout - French")

Voilà !


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]