MAC OS X: Forum

Major Catalina Catastrophe

COW Forums : Apple OS X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Jim Curtis
Major Catalina Catastrophe
on May 7, 2020 at 2:43:25 pm

Sorry for the long post, but I've tried to provide the relevant facts.

My 2019 MacPro stays on more or less constantly, but I shut it down Sunday night when I heard thunder approaching. I routinely do this to protect my gear from spikes, even though I have it an my RAIDS (I have two.) connected to a APC UPS. On Monday morning, after I booted, I noticed my desktop had changed, Mail wasn't working right, and my Contacts had disappeared. This wasn't the first time this has happened with Catalina. So, I reinstalled Catalina after booting from a recovery flash drive, and then copied my User Folder from the clone I made Saturday using ChronoSync. That restored my boot disk, or so I thought.

I then noticed several catastrophic facts: Almost all the projects and media on my two RAIDs had been erased. I also noted several third party apps had vanished from my boot disk.

I have two RAIDs on my Mac because I'm paranoid about data loss. The smaller 24TB OWC TB3 DAS RAID is intended as temporary backup to the 126TB QNAP NAS RAID until I can backup to an LTO tape. I lost around 50 TB of files. Freakout time!

I have three suspicions about what happened.
(1) malware attack. I ran the CleanMyMac malware finder, and it found no incidences.
(2) total FUBAR of Catalina 10.15.4
(3) Prior to shutting down Sunday night, I tried to make a LTO tape using ArGest Backup 4.0.6. I dragged a folder into the backup area and clicked Continue. Then a window came up in which I DESELECTED Estimate Archive Size, and then clicked the button to proceed. The app ignored my desire to Estimate, and proceeded to list thousands of files. This went on FAR LONGER than I'd ever seen, but I was going to let it run. After about five minutes is when I heard the thunder, so I force quit the app (with no other way to interrupt the process), and shut down my computer, NAS and RAID.

Since I reinstalled Catalina and my User folder on Monday morning, I probably destroyed any logs that might have helped me to determine what I can blame this on with any degree of certainty.

If anybody has any theories, I'd love to hear them. And, I'm also posting this as a warning to other Catalina and perhaps ArGest users to be careful. I hate to indict any innocent parties here, but as you know, if you've been dealing with computers long enough, the last thing you did before a meltdown is the most likely suspect.

It's possible that Catalina was whacked first, then cascaded an issue with ArGest Backup, or vice versa, creating a perfect storm.

Epilog: I searched for an app to un-delete files, and DiskDrill has been finding files for the past two days, and I've been able to restore MOST of the projects and media I hadn't yet written to tape. I still have hours to go before I'll know if there's any corruption of my files, or how much. DiskDrill works on my OWC RAID, a DAS via TB3, but it DOES NOT recognize the NAS, which mounts as a shared disk. That's cause for concern.

Jim Curtis
jamesphilipcurtis.com

MacPro7,1 24-core - 256 GB RAM - AMD Radeon Pro Vega II 32 GB - 10.15.4 (Warning: Don't do the Supplemental Update!)


Return to posts index

Jim Curtis
Re: Major Catalina Catastrophe
on May 18, 2020 at 12:57:00 pm

No comments, eh? It was the length, wasn't it? Or, you all think I'm nuts, and this never happened?

Now that some time has passed, and I've had time to attempt to deduce what went wrong, I'm concluding that this catastrophe was a perfect storm of a shitty OS and some beta software.

This is based on the fact that right before I shut down, and started to run a job with ArGest Backup, the Estimate Size was displaying hundreds of file names (which is usual), but it went on for about five minutes, (which is UNusual - usually takes 30 seconds or less). It's my theory that ArGest and Catalina were working in tandem to delete files willy nilly. I did a force quit, and shut down my computer (due to lightning and thunder nearby). It was after I booted in the morning that I noticed my issues. It's usually the last thing you did that caused your problem.

===

I just reinstalled Catalina for about the seventh time, due to multiple Finder hangs over the weekend. I got the spinning ball for about a minute or two after doing something routine like clicking on a disk icon, or renaming a folder.

Over the weekend, I upgraded my old ATTO SAS Enhance RAID with eight 12 TB SATA drives. Now, I have two massive RAIDs, and I can keep one switched off when I'm not doing backups, which should protect it from any future similar catastrophes. BTW, this old RAID kicks ass on my QNAP NAS in terms of io - about 40% faster read and writes according to the BMD disk speed tester.

Jim Curtis
jamesphilipcurtis.com

MacPro7,1 24-core - 256 GB RAM - AMD Radeon Pro Vega II 32 GB - 10.15.4 (Warning: Don't do the Supplemental Update!)


Return to posts index

Rainer Wirth
Re: Major Catalina Catastrophe
on May 19, 2020 at 9:09:38 am

Hi Jim,

I have read it but didn't know what to say,
because whats happened to you is horrible.
I wouldn`t even want to think about it.
I just thought: What lucky I was never touched Catalina and what a mess
for people who are stuck with it. Especially when you bought a new macPro
for a couple of thousands of dollars.
I hope you can cope with it

cheers

Rainer

factstory
Rainer Wirth
phone_0049-177-2156086
Mac pro 8core
Adobe,FCP,Avid
several raid systems


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2020 CreativeCOW.net All Rights Reserved
[TOP]