MAC OS X: Forum

OSX 10.4 on 2004 imac?

COW Forums : Apple OS X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Lynne Desjardins
OSX 10.4 on 2004 imac?
on Feb 26, 2009 at 4:40:43 am

Does OSX 10.4 require an intel-based mac? I would like to install final cut studio 5 into an older imac. Can I install 10.4, or would I be better off trying to find an older version of final cut for this specific computer?

Lynne Desjardins


Return to posts index

Zane Barker
Re: OSX 10.4 on 2004 imac?
on Feb 26, 2009 at 3:00:58 pm

No 10.4 does not require an intel proceser it was actualy released over a year before apple started using intel chips.

I don't know where you will be able to purchase a copy of 10.4 though it has not been sold for over a year.

The other issue you might run into is I don't know if your FCP will let you install it on an old iMac like that, it may not meat the system requirements.

There are no "technical solutions" to your "artistic problems".
Don't let technology get in the way of your creativity!



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]