MAC OS X: Forum

Can't repair permissions!

COW Forums : Apple OS X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Kieran MatthewCan't repair permissions!
by on Feb 13, 2006 at 4:47:24 pm

Hi there,
I'm running 10.3.9 on a Dual 1.42 G4 - recently it started behaving a bit oddly so I decided to repair permissions on my internal hard drive.

Disk utility starts checking but then crashes with an error message "Disk Utility has lost its connection with the Disk Management Tool and cannot continue". This also happens if I boot from the install CD and try from there.

Apart from reformatting and reinstalling, is there anything I can do/download/enter to help overcome this?

Thanks in advance


Return to posts index

Don GreeningRe: Can't repair permissions!
by on Feb 13, 2006 at 5:35:19 pm

Yes there is. Drag your iTunes v.6.0.2 to the trash but DON'T delete. Restart your Mac and run Disk Utility again. This workaround proved successful for someone in the FCP forum last week. Once you've repaired permissions then drag iTunes back out of the trash.

In the new version of iTunes is a program that runs in the background called iTunes Helper. It seems to be messing up Disk Utility when you go to repair permissions. The permanent fix is to go back to iTunes v.6.0.1. OR...trash the Mac chess game (of all things).

Here's a link to the FCP thread:

http://forums.creativecow.net/cgi-bin/new_read_post.cgi?univpostid=881960&f...

- Don


Return to posts index

Kieran MatthewRe: Can't repair permissions!
by on Feb 13, 2006 at 5:52:04 pm

Sorted!

Many thanks for the fast reply - you're a star!

Kieran


Return to posts index


Don GreeningRe: Can't repair permissions!
by on Feb 13, 2006 at 6:09:19 pm

Kieran,

Keep in mind that I have no proof that the iTunes Helper program within iTunes v.6.0.2 is the actual culprit, but since it's not in v.6.0.1 the logical conclusion is that it may be what's causing Disk Utility to crash when repairing permissioins. Since I don't have iTunes 6.0.2 anymore I can't run a test to see if turning off ITunes Helper within iTunes would fix things for Disk Utility.

- Don


Return to posts index

Marco D.Re: Can't repair permissions!
by on Apr 10, 2006 at 3:02:01 pm

Just a short note to let you know I had this problem too. I tried everything, running Disk Utility in OS X, from the boot CD, I tried fsck -fy on system boot, etc. To no avail. When I tried the suggested fix of tossing iTunes 6.0.2 to the Trash, restarting and running Disk Utility again, I was able to fix and repair my permissions :-)

Now, it didn't solve the problem I had in the first place, which was that DVD Player always crashes (unexpectedly quits) when trying a few VIDEO_TS on my media drives... :-( I'll post separately for that issue, but thanks for the permissions fix!

Marco


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]