ZAXWERKS: Zaxwerks Forum Zaxwerks Tutorials

Lathe Object Build Angles

COW Forums : Zaxwerks

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Austin Reeves
Lathe Object Build Angles
on Jun 13, 2014 at 4:04:42 pm

Trying to build a scene with several rings. Full Lathe objects work wonderfully. However, if I tweak any build angles to those objects I get artifacting on the caps. All my rings are built in primitive shapes, no customs, just circles, ovals, and polygons.

Correct me if I'm wrong, but seems a valid way of setting up less than full circular lathe objects.



---
Austin Reeves
AR&C
http://www.austinreeves.com
Production & Post-Production Services
Washington, DC


Return to posts index

Matt Rhodes
Re: Lathe Object Build Angles
on Jun 13, 2014 at 4:50:51 pm

Hi Austin.

There does seem to be some incorrect geometric artifacts at the end of the build angles.
This seems to be a bug.

As a workaround, you may try to create your lathe shapes centered around the X axis.


You'll have to further adjust your scene, but you should be able to get rid of the artifacts
until a fix can be sent out.

Let us know if you have any other questions.

Thanks.

Matt Rhodes
Zaxwerks, Inc.



Return to posts index

Matt Rhodes
Re: Lathe Object Build Angles
on Jun 13, 2014 at 9:25:09 pm

Hi Austin.

Can you tell me which version of which product you're running,
and on which platform?

I may have a fix to send you.

Thanks.

Matt Rhodes
Zaxwerks, Inc.



Return to posts index


Austin Reeves
Re: Lathe Object Build Angles
on Jun 13, 2014 at 9:50:02 pm

ProAnimator 7.0.1 AE & Standalone
Mac OS 10.9.3
AE CC 12.2.1.5

Thanks Matt for the quick response! I looked on the Zax site but couldn't see what the current release is and if there is an update.

---
Austin Reeves
AR&C
http://www.austinreeves.com
Production & Post-Production Services
Washington, DC


Return to posts index

Austin Reeves
Re: Lathe Object Build Angles
on Jun 13, 2014 at 10:08:23 pm

Un unrelated issue, but something thats got me stumped as well (may or may not be intended behavoir in other words)

Let me see if I can set the scene:
Flat disc (lathe object somewhat like a donut)
Logo Object (AI paths extruded) sitting ontop of the disc
Logo object parented to Null at center of disc allowing me to use rotation of null to orbit the Logo object around the lathed ring.
All works great.

Apply Warp to Logo Object to bend it to the radius of the lathe ring works, but the warp does not following the parenting setup of its parent track. The warp stays at its location causing odd behavior as the the object its applied to rotates around. There seems to be no way to parent the warp to the null.

This may be intended behavior, just wanted to pass it along in case.

---
Austin Reeves
AR&C
http://www.austinreeves.com
Production & Post-Production Services
Washington, DC


Return to posts index

Edward Wu
Re: Lathe Object Build Angles
on Jun 16, 2014 at 9:20:13 pm

Hi Austin,

For the warp you are trying to set up, you can consider exporting the warped object as a .obj model and be sure to bake the transformation. After doing this, re-import the object and the object will have the warp applied to it already. Then, you can parent the warped object to the parent track and it should work without any problems.

Hope this helps. If you have any additional questions, please let me know.

Best,
Edward


Return to posts index


Austin Reeves
Re: Lathe Object Build Angles
on Jun 18, 2014 at 6:47:44 pm

Edward thank you! I didn't realize exporting the object would bake the warp! I'll try that today.

---
Austin Reeves
AR&C
http://www.austinreeves.com
Production & Post-Production Services
Washington, DC


Return to posts index

Edward Wu
Re: Lathe Object Build Angles
on Jun 18, 2014 at 7:01:40 pm

Hi Austin,

No problem at all! Have fun with the project!

Best,
Edward


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]