ZAXWERKS: Zaxwerks Forum Zaxwerks Tutorials

Issues using Material with Specular Attributes with Shadows

COW Forums : Zaxwerks

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Holt AdamsIssues using Material with Specular Attributes with Shadows
by on Jan 27, 2013 at 9:53:05 pm

I'm having issues with AE rendering when my ProAnimator Layer utilized material with Specular attributes. (e.g. highlight Sharpness: 7, Highlight Brightness: 84) with a Gradient defined for a 3D logo. I also have other 3D Text objects defined with the same material that have shadows.

While in ProAnimator if I choose either Invigorator Renderer or Ray Tracer...... the Test Render doesn't include any highlights (while the preview shows the highlights...a bit surprising). If I use the OpenGL Renderer....I get highlights shown in both the preview and the Test Render......which at first appears to be good news...but while I'm back in AE the OpenGL Renderer settings of ProAnimator results in all sorts of partial, scatter renderings (both in RAM Preview and when Rendering with Best Quality out to a file...not to mention AE often crashes). For me using OpenGL is not a good thing.

If I use Invigorator Renderer or Ray Tracer as ProAnimator settings and enable Use Comp Lighting (Note I have no Light layers in AE).....I do see the specular highlights while in AE on both my 3D Logo and 3D Text. Which also appears to be good news for my 3D Logo....but my Scene in ProAnimator includes shadows for my 3D Text that are suppose to fall on a material setup as a Shadow Catcher. for my 3D Text the shadow do not appear...which is what I'm expecting since in AE I have no lights setup. I could setup a light layer in AE and create some shadows for my 3D Text...but that creates all sorts of other affects that I'm not wanting to deal with at this time.....so for now I'm trying to use ProAnimator to create a scene that I should be able to do.

My question is.....what must I do to get both specular highlights to show up and to have shadows on the same object (my 3D Text objects) using ProAnimator settings.

I've spent a lot of time trying to figure out the inconsistencies ...which I put into a mind map.
5323_proanimatorissueswithspecularattributes.pdf.zip

I appreciate any insight or suggestions.

Holt

I'm using AE CS5 an ProAnimator V6.1.0


Return to posts index

Edward WuRe: Issues using Material with Specular Attributes with Shadows
by on Jan 28, 2013 at 8:59:13 pm

Hi Holt,

One of the reasons why you may be seeing different results in the 3D Preview window as opposed to the Render Test is because you are working with shadows. Even though shadows do show up when using the OpenGL Renderer/3D Preview window, the shadow that is generated is more of a draft quality shadow rather than the final quality shadow that is generated when you click the Render Test button. Also, keep in mind that if you enable the "Ambient Occlusion" feature, this will darken corners and other areas where objects are close to one another. This means, while objects may appear bright with the OpenGL renderer, once the Ambient Occlusion is applied, certain appears may appear darker and cause the highlight to not show up, or be darker than it otherwise may be.

Hope this helps. If you're still having problems, please send the project file to me at ed@zaxwerks.com. I do not need the media files. You can just send the raw After Effects project and I will be able to see your ProAnimator set up.

Best,
Edward


Return to posts index

Holt AdamsRe: Issues using Material with Specular Attributes with Shadows
by on Jan 29, 2013 at 5:44:47 pm

Ed

Hey there...I think have two Problems
1) Specular highlights are not being rendered when I use Invigorator Renderer or the Ray Tracer Renderer with lighting defined within ProAnimator. This is true for when I use the Test Render control in ProAnimator and when I use AE Ram Preview or actual render out to a file from AE. Its interesting that if I define a light within AE and set ProAnimator to Use Comp Lighting then the Specular highlights do appear when rendering? Hmmmmm

2) When using OpenGL Renderer AE / ProAnimator renders partial frame misplaced content, scattered pixels or Crashes.

I'll send you an email with screen shots and a simplified version of my project.

Thanks, Holt





Return to posts index


Edward WuRe: Issues using Material with Specular Attributes with Shadows
by on Jan 29, 2013 at 6:55:08 pm

Hi Holt,

Thanks for sending the project file. Please see my reply. Somehow, your project is not working correctly and the Specular Highlights are not working. Please use my attached project file and see if you are still experiencing the same issues.

Best,
Edward


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]