ZAXWERKS: Zaxwerks Forum Zaxwerks Tutorials

3D reflector with invigorator model. Problem with updating reflections.

COW Forums : Zaxwerks

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Mike James
3D reflector with invigorator model. Problem with updating reflections.
on Mar 23, 2012 at 4:18:17 am

Try as I might I can't get a 3D Invigotator model to work with 3D reflector properly.

For example, and to keep things simple for teh sake of this post; I create a floor with an AE 3d layer, and over the top of the floor, I create a simple 3D primitive (a cube in this case) with Invigorator Pro. I apply 3D reflector to the AE floor layer, and also untick "Hide 2D layers". This is fine. In static scene, I get the reflection of the 3D cube in the AE 3d floor layer.

My main problem comes when I try to animate an AE camera around the cube. When I do this, the reflection remains static and does not move/update to reflect the way that it should do when the camera moves around it.

What am I missing? :)


Return to posts index

Edward Wu
Re: 3D reflector with invigorator model. Problem with updating reflections.
on Mar 23, 2012 at 7:52:38 pm

Hi Mike,

After moving the After Effects camera around, have you clicked on the Update Reflector button? You can also open up the Reflector Updater script which will make updating the reflections easier. After creating a camera move, click the Update Comp button and it will re-calculate the reflections based on the Camera move.

Hope this helps.

Best,
Edward


Return to posts index

Mike James
Re: 3D reflector with invigorator model. Problem with updating reflections.
on Mar 23, 2012 at 8:48:12 pm

Thanks for the reply, Edward.

To answer your question yes, I was using the updater script to update the comp, but that didn't seem to be working.

Now I think I've identified what my problem is. In the comp I described above I had my AE camera parented to a null object (makes it easier to control the camera, especially with orbits as you will know). I think for some reason, 3D reflector doesn't like the camera being parented because if I remove the null object/parenting, and animate the camera directly, then the reflections DO work properly, but the moment I parent the camera to a null, then the reflections stop updating.

Mike.


Return to posts index


Edward Wu
Re: 3D reflector with invigorator model. Problem with updating reflections.
on Mar 26, 2012 at 11:31:33 pm

Hi Mike,

That's right. The camera cannot be parented. Otherwise the reflections will not update correctly. Glad to hear that you were able to figure out what was causing the issue for you.

Best,
Edward


Return to posts index

Brent Willett
Re: 3D reflector with invigorator model. Problem with updating reflections.
on Mar 29, 2012 at 8:28:06 am

Hi Mike,

I have what may be a work-around for this.

Set up your project like you described with the camera parented to a null, using the null to control the movement of the camera. Then add a keyframe to one of the values (for instance "Point of Interest") of the camera, update your Reflector layer, and it should work just fine. You don't even need to actually animate the camera, just add one keyframe.

I don't know if it will work in all situations, but I have done some fairly complicated projects in which the camera was controlled by nulls, and there were even multiple layers using the ProAnimator effect, and the reflection worked perfectly.

I hope it works for you.

Thanks,
Brent


Return to posts index

Edward Wu
Re: 3D reflector with invigorator model. Problem with updating reflections.
on Mar 29, 2012 at 7:15:30 pm

Hi Brent,

Wow. You're absolutely right about the workaround! It works great. Thanks for sharing this hot tip!!!

Best,
Edward


Return to posts index


Mike James
Re: 3D reflector with invigorator model. Problem with updating reflections.
on Mar 29, 2012 at 11:11:35 pm

That's brilliant, Brent! Thank you for the info. :)


Return to posts index

Brent Willett
Re: 3D reflector with invigorator model. Problem with updating reflections.
on Mar 30, 2012 at 2:21:12 pm

I'm glad it works for you!

As with many tips, tricks, and workarounds, I stumbled on this by accident. I'm just happy I was able to be of help.

Thanks,
Brent


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]