ZAXWERKS: Zaxwerks Forum Zaxwerks Tutorials

The old 'Y' rotation issue

COW Forums : Zaxwerks

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Steve McGarrigle
The old 'Y' rotation issue
on Aug 19, 2011 at 1:46:36 pm

Hello.

Firstly i am using ProAnimator V4.5.1.

I have an animation where some text flies towards the camera, springs to a halt and then is supposed to rotate around a common centre on it's Y axis and then fly off towards the viewer.

My problem arises at the rotate along Y axis point.

In creating the rotation as a transition, two issues arise.
The first is that during the rotation the letters appear to bunch up together however as the rotation is pretty fast the motion blur may disguise this, so not a major issue.
The second and main problem is that when playing back the animation nothing happens.

It's almost as if the code thinks +360 and -360 are the same as 0 so don't bother to apply rotation.
I can achieve a perfect rotation as a pose action but then i loose the ability ease in and out the acceleration and deceleration.

My questions then are, Is this a bug? Is it possible to somehow add ease in and out to a pose action? or is there another workaround for doing this as a transition?

Thanks in advance for your time on this.

Steve


Return to posts index

Edward Wu
Re: The old 'Y' rotation issue
on Aug 19, 2011 at 5:40:46 pm

Hi Steve,

For the issue where your text is getting bunched up, you can use Transition Grouping to help keep all your text characters together. Go to Timing Section in the Transition, and under the Transition Grouping menu, select the "Make Hard Group" command. This will group your objects together so they don't move during a transition.

As far as spinning your object in a Transition, go to Path Actions, and select "Spin Y" in the "Action" menu. Then you can enter a value of "360" and it will spin your objects. You're right that the "Rotate Around Common/Local Centers" does not spin your object if you position it at 360, so that's why you need to use the Spin Y action.

Hope this helps. If you have any questions, let me know.

Best,
Edward


Return to posts index

Steve McGarrigle
Re: The old 'Y' rotation issue
on Aug 21, 2011 at 2:13:39 am

Thanks for your help Edward - project is back on track!

Much appreciated.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]