ZAXWERKS: Zaxwerks Forum Zaxwerks Tutorials

3D invigorator layer map problem

COW Forums : Zaxwerks

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
LIquid
3D invigorator layer map problem
on Oct 21, 2005 at 2:52:24 pm

Hi there, It seems that I am testing the plug-in to its limit. I am working on a project for a friend who is a light designer. He just developed a beautiful lamp which is filled with a red liquid. When you switch it on the liquid rises up the neck of the lamp because the heat of the light bulb makes it expand. My friend asked me a favour to animate a little preview of his product. This was the perfect opportunity for me to test 3D invigorator. But I came across a problem which concerns the animation of the rising liquid.
As you can see on the picture under:
http://www.petermock.homechoice.co.uk/light.jpg
... I used a layer map in 3D invigorator which consists of a comp containing a solid layer which moves from bottom to top to fill the screen with red. This layer map was used
for the 'Highlight sharpness' - property which was set to 200.
The animation itself works fine and simulates beautifully the liquid rising up the neck of the lamp. But the problem i came across is that as soon as i move my camera closer to the lamp the liquid inside (the red layer map) won't rise smoothly anymore and moves in steps. It seems that the invigorator only calculates the animation steps for the original shape but as soon as you zoom in on it the time resolution isn't adjusted.
As you can see:
http://www.petermock.homechoice.co.uk/light.mov
Any idea how to get out of this .... ?
Thanks
Peter
_____________________________________________________________
Ok, now I tried everything:

I tried to scale all: object, custom edges of the object and layer map (continuously rasterized) to minimise the scaling effort of 3D invigorator
... I rendered the layer map with max. time resolution (99fps) to offer as tiny animation steps as possible,
... and I moved the track layer linked to the object close to the camera instead the camera close to the object.
All these attempts lead to the same result, the animation set up in the layer map won't run smoothly on the object.
Am I blind not to see what is wrong or am I just getting to Zaxwerks 3D invigorators limits?

The problem is ... I need to find a solution, so if anyone knows a way out of this I am glad to hear it.
Thanks guys
Peter



Return to posts index

serge
Re: 3D invigorator layer map problem
on Oct 22, 2005 at 1:47:19 am

Hi peter,

I tried and tried to replicate your problem to no avail. What version of Invigorator are you using?
Are you rendering with fields? How does it look when you RAM preview?
Just a thought, what about enabling motion blur for the red texture layer?
You could send me the aep (serge at nyc-visual dot com) I'll have a look at it and see if I can help.

Salut.
Serge


Return to posts index

serge
problem solved
on Oct 24, 2005 at 5:53:26 am

Hi Peter,

After spending a couple of hours on the project you sent me I finally pinpointed the issue:
Your custom edge was so elongated that it created an object that needs a much higher resolution map then the one you created. The unsmooth animation was due to artifacts. Changing your map composition settings to something like 3000 X 3000 pixels (Your red layer should be reset to comp size and its position properties should also be altered to fit) should get you a smooth animation.
Also right before your final render set the Object Faceting (Best & Draft) to 0.01 instead of 0.1 by typing in the values to get a smoother object. I also noticed that you were working in 16 bpc what was not necessary at all especially that a jpeg sequence (In your render queue) doesn't support it anyway.

I liked what you did with the lamp! Looks very cool.
Please let me know when your friend goes in production as I would love to buy one.

Salut.
Serge


Return to posts index


LIquid
Re: problem solved
on Oct 24, 2005 at 12:34:41 pm

HI SERGE,

thanks for your reply. I implemented your suggested solution and started a new render - 9 hours for one lamp shape - that brings the deadline into the danger zone.
I hope the issue will be solved then. I keep you posted about the results,
Thanks for sending so much time with my problem,

Peter


Return to posts index

LIquid
Re: problem solved
on Oct 25, 2005 at 1:31:11 pm

Hi Serge,

well I changed the Object Faceting (Best & Draft) from 0.01 instead back to 0.1 but maximised the Layer map size from 3000x3000 to 4000x4000. I had to use the comp lights and I rendered it at 8bpc. The result for a 70s long movie was about 4 hours. I think the reduction down from 8 hours was because of chanfe of the Object Faceting settings. But still I can see jumps in the animation of the layer map...
Many thanks
Peter

On 25 Oct 2005, at 03:05, Serge Hamad wrote:

Hi Peter,

Just interested to know about your 9 hours render. Did you render at 16 bpc? Also I believe that using Invigorator own lights could help reduce the render time. You should run a short benchmark test for the future.
Good luck

Regards.

Serge


Return to posts index

serge
Re: problem solved
on Oct 25, 2005 at 6:23:26 pm

[LIquid] "But still I can see jumps in the animation of the layer map..."

That is strange. I did a small render of your project changing slightly the speed of the map animation and changing your comp settings to 50fps as well as checked the "Preserve frame rate..." in the advanced menu and the result didn't look bad to me.
Here is a very compressed version:
http://www.nyc-visual.com/lamp1.mov

Salut.
Serge


Return to posts index


LIquid
Re: problem solved
on Oct 25, 2005 at 9:05:10 pm

Did you change the frame rate of the layer map or the comp or both?
Thanks
Peter


Return to posts index

serge
Re: problem solved
on Oct 25, 2005 at 9:41:09 pm

Hi,

I changed the frame rate of the map composition only. I rendered the main comp at 25fps.
Adjusting the speed of your animated red layer inside of the map comp helped already.

Here is the aep:
http://www.nyc-visual.com/lamp2.zip
Good luck.
Serge


Return to posts index

LIquid
Re: problem solved
on Oct 26, 2005 at 9:00:54 am

Hi Serge,

... here is a short clip of my render results:
http://www.petermock.homechoice.co.uk/test50fps.mov
Peter


Return to posts index


serge
Re: problem solved
on Oct 26, 2005 at 4:14:39 pm

Peter,

That looks nasty! I noticed that you were using a bunch of other maps in your first AEP. Invigorator crashed on me each time I tried to replace them. Send me your final AEP including the maps (jpegs) you are using. You may also want to use my project for now untill we repair yours.

If you send your aep right away I will have time to look at it at once.

Salut.
Serge


Return to posts index

LIquid
Re: problem solved
on Oct 26, 2005 at 5:12:20 pm

Serge,

here you go:
http://www.petermock.homechoice.co.uk/lamp%20folder2.sit

Good Luck,
Peter


Return to posts index

serge
Re: Now for sure
on Oct 26, 2005 at 6:13:01 pm

Hi,

Switch off the collapse transformations for your Liquid 01 composition. You will need to readjust the animation of your red solid inside of the comp. You cleared the issue by following the first tip (Larger map) but the collapse transformations reintroduced the artifact.

Let me know how it works.

Here is the corrected AEP:
http://www.nyc-visual.com/lamp_2.zip

Matt or Zax if you are reading this post could you please check this project as it crashes pretty much AE with memory leaks...

Salut.
Serge


Return to posts index


LIquid
Re: Now for sure
on Oct 27, 2005 at 4:55:35 pm

Hi Serge,

thank you so much, it worked. The 'Preserve Framerate' option in the Advanced object settings was the key.
It runs absolutly smooth now!

Thanks a lot

Peter


Return to posts index

Serge
Re: Now for sure
on Oct 27, 2005 at 5:08:58 pm

Ah! Very glad to hear that Peter.

All the best.
Serge


Return to posts index

LIquid
Re: Now for sure
on Oct 27, 2005 at 5:39:33 pm

And to you too, I learned a lot,
Peter


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]