APPLE FINAL CUT PRO: Apple Final Cut Pro X FCPX Debates FCP Legacy FCP Tutorials

"Move Event" to new library deletes files

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Dave Smith
"Move Event" to new library deletes files
on Aug 27, 2019 at 6:01:22 pm

Hi folks, I'm looking for a little clarification on how FCP should act when moving Events to different libraries.
Some how I feel like I've asked this before but it's just not sinking in. I think this stumbling misunderstanding is why I've lost footage in the past.

I have two 4tb Lacie raid drives for video projects. Each one has a managed library on it containing respective footage (so they are self contained libraries): drive 1 is working library where I do most of the work .... drive 2 is archive library. If I feel like an Event is just taking up space on the working drive and don't expect a future need for the footage I move it to the archive drive. To do this I open both libraries in FCP, hold down the command modifier key while dragging the Event from the working library to the archive library... the 'Move' dialog pops up asking if I also want to move the transcoded and proxy media, I click 'Yes' and the process begins.

Afterwards I double check the Event and all footage has moved to the archive library and drive properly, and notice all the files in the moved event are 'missing'... Show in Finder reveals takes me to the archive library's 'Original Media' folder (on the archive drive), but oddly they are only 0kb aliases to themselves. (ie. Get info on the alias shows the "Original:" as the current location of the 0kb alias).

In a panic I rush back to the working drive and 'Show contents' of the working library to see if the files were left in their original location by chance... they are not. Thankfully I found them in a folder something like "LibraryName/_Trash/EventName_randomCharacters/Original Media" along with all the other render files and transcoded media for the event I just moved.

Not realizing this is how FCP works is probably why I've lost real footage in the past while "Moving" events between libraries. Can anyone help me understand why 'Moving' and event to a different library doesn't actually move it along with the files as the Move dialog indicates?

I'm obviously missing some key piece of information and it's causing much frustration when trying to manage Libraries and Events. Particularly, Apple's page on this topic says "When you move an item from one library to another, the corresponding files are moved from the library file in the first storage location to the library file in the second location." from https://support.apple.com/kb/PH12766?locale=en_US

I've followed this page's information closely and don't know what I'm doing wrong. Help!! Gracias!!


Return to posts index

Jeremy Garchow
Re: "Move Event" to new library deletes files
on Aug 28, 2019 at 2:56:29 am

First, double check the media in the archive library is set so the media actually is managed in to the Library.

Second, have you tried the File > Move Event to "Archive Library" command within FCPX from the original Library with the Event you want to move selected?


Return to posts index

Dave Smith
Re: "Move Event" to new library deletes files
on Aug 28, 2019 at 1:41:13 pm

Yep ok, i'll try those suggestions. Thanks!


Return to posts index


Joe Marler
Re: "Move Event" to new library deletes files
on Aug 28, 2019 at 8:53:07 pm
Last Edited By Joe Marler on Aug 28, 2019 at 8:54:00 pm

On FCPX 10.4.6 I don't see an option to move an event between libraries, only copy an event. On my system the move menu option is greyed out. Using CMD and drag/drop makes the + (copy) graphic go away but upon mouse release the event just blinks away indicating a "no move".

I recommend you copy the event across libraries, verify it's at the destination, then delete the original event within the source library. When you delete the original event, the media files within the managed library are deleted and temporarily placed within a _Trash folder inside the library. Upon FCPX restart that temp folder is deleted.

Make sure all your hard drives are formatted HFS+ (Mac OS Journaled), not exFAT or anything else.


Return to posts index

Jeremy Garchow
Re: "Move Event" to new library deletes files
on Aug 28, 2019 at 10:46:33 pm

Weird, shows up on mine,

You need two libraries open, and the Event that you want to move selected.

Menu here:





And David, Joe is right, check your hard drive format or permission. It sounds like you may not have write permissions, or the drive is not formatted for Mac.


Return to posts index

Dave Smith
Re: "Move Event" to new library deletes files
on Sep 10, 2019 at 1:45:34 pm

So i think this problem i had was because the library for my archive was set to keep files on the working drive... my oversight then. Could have sworn I had this set correctly but i guess not. Thanks for the help.


Return to posts index


Dave Smith
Re: "Move Event" to new library deletes files
on Aug 28, 2019 at 11:32:08 pm

Thanks for the help... maybe i can help you. The problem you're having "On my system the move menu option is greyed out." could be a result of trying to move the last Event out of a Library... Final Cut won't let you do that. You have to create a second Event so that there is at least one Event left in the Library before the File > Move becomes available. =]

I'm testing my issue using File > Move instead of drag/drop like i did the first time... fingers crossed.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]