APPLE FINAL CUT PRO: Apple Final Cut Pro X FCPX Debates FCP Legacy FCP Tutorials

Just Discovered Archiving Libraries Doesn't Work.

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Ken Bennett
Just Discovered Archiving Libraries Doesn't Work.
on Sep 12, 2018 at 9:10:39 pm
Last Edited By Ken Bennett on Sep 12, 2018 at 9:22:07 pm

I just started going back to look at a few of my Library projects that I've archived in FCPX. Then I find a number of Missing Files!!!??? And on some of the Projects all the files are Missing Files. In all my Libraries I copy all video and audio files into the library so it is self contained. Everything works fine during the editing process. But after it's been archived, files go Missing.

The process: I delete rendered files, optimized media and proxy media to reduce Library file size and copy the Library onto another drive. Then I reset the cache location, and then i open this archived Library and consolidate. Then delete the cache folder and delete the original Library.

Now days later when I reopen the archive file, things are now Missing Files. So I can't trust archiving anymore.

Any idea why FCPX can't archive 100% of the time?

Ken Bennett
Video Adventures
Capturing Your Life's Adventures!


Return to posts index

Jeff Kirkland
Re: Just Discovered Archiving Libraries Doesn't Work.
on Sep 13, 2018 at 4:00:28 am

I don't really trust archiving in any NLE. I always test on another machine or with the original drive offline before I consider it safe to delete anything.

What's your procedure for archiving? Just wondering if you're maybe missing a step somewhere...

----
Jeff Kirkland | Video Producer & Cinematographer
Hobart, Tasmania | Twitter: @jeffkirkland


Return to posts index

Eric Santiago
Re: Just Discovered Archiving Libraries Doesn't Work.
on Sep 13, 2018 at 4:59:17 am

Not archiving but your workflow is similar to mine of late and it been a nightmare.
Hope you find a solution and please share here.


Return to posts index


Jeff Kirkland
Re: Just Discovered Archiving Libraries Doesn't Work.
on Sep 13, 2018 at 6:04:09 am

Hoops - read that a bit too quickly and just realised the workflow was in the post. The only step I see missing is testing the archive before deleting the original.

Just wondering are you creating the archive on the same drive or a different drive? I've had consolidation not work the way you'd expect if the two libraries are on the same physical disk.

----
Jeff Kirkland | Video Producer & Cinematographer
Hobart, Tasmania | Twitter: @jeffkirkland


Return to posts index

Bret Williams
Re: Just Discovered Archiving Libraries Doesn't Work.
on Sep 13, 2018 at 7:03:09 am

I’ve never had an issue. Here’s what I do-

Highlight the final sequence(s) and choose to create a new library from project. I do this to the same drive btw. i don’t copy over any proxy or optimized. Then, in the new library make sure the media is set to inside library and then press consolidate. This will be instantaneous because it’s the same drive and it just creates hard links. it’s going to leave a library with just the final project(s) and mediarequired. I don’t trust anything either. Open the package and check the original media folder and sort by type. If there aren’t any aliases, you’re good! If you had any external media, there’d be an alias. Every file in a library is represented here as a file or an alias. Occasionally I’ve found an alias only to discover that the file didn’t exist anywhere. Like a file I had turned off on the project, and it was originally just a quick test file from the downloads folder or Dropbox that is long gone.

_______________________________________________________________________
http://BretFX.com FCPX Plugins & Templates for Editors & Motion Graphics Artists
Hang Tag http://bretfx.com/product/hang-tag
Overshoot Text http://bretfx.com/product/overshoot-text/
Outliner http://bretfx.com/product/outliner/
Clock Maker http://bretfx.com/product/bretfx-clock-maker/


Return to posts index

Ken Bennett
Re: Just Discovered Archiving Libraries Doesn't Work.
on Sep 13, 2018 at 5:36:25 pm

Well that leaves me with a nice warm and fuzz feeling of archiving important projects. I'm working on a 50 episode documentary series and I will need access over time for re-editing, changing, updating material. If I can no loner trust FCPX's archiving process I will have to keep ALL raw data on backup RAIDs.

Ken Bennett
Video Adventures
Capturing Your Life's Adventures!


Return to posts index


Bret Williams
Re: Just Discovered Archiving Libraries Doesn't Work.
on Sep 13, 2018 at 8:40:20 pm

So did you misunderstand part of my post? In 7 years it's never failed me. Solid. Did it the same similar way even before the 10.1 interface change. It takes about 3 seconds to archive anything.

_______________________________________________________________________
http://BretFX.com FCPX Plugins & Templates for Editors & Motion Graphics Artists
Hang Tag http://bretfx.com/product/hang-tag
Overshoot Text http://bretfx.com/product/overshoot-text/
Outliner http://bretfx.com/product/outliner/
Clock Maker http://bretfx.com/product/bretfx-clock-maker/


Return to posts index

Ken Bennett
Re: Just Discovered Archiving Libraries Doesn't Work.
on Sep 13, 2018 at 5:26:57 pm

Jeff, as far as I remember I do open the archived Library, which is stored on another drive, for sanity sake. But often when I need to go back for whatever reason, this is when I see some missing files. In some cases entire project files are missing. And I always copy my raw footage into the Library to keep it all in one place.

Ken Bennett
Video Adventures
Capturing Your Life's Adventures!


Return to posts index

Bret Williams
Re: Just Discovered Archiving Libraries Doesn't Work.
on Sep 13, 2018 at 8:51:38 pm

Perhaps you're just seeing red clips because plug-ins are offline after so long? I have a solution for that too.

First off, consolidating motion content into the archive library doesn't work. It's a bad idea. Don't do it. As you bring the project back, the plugins will end up duplicated into your effects browser but with t new "copy 1,2,3" appended and once you've done that, now you have to keep those copy versions as well because now your project is linked to them. Not good.

Ok, that said, when I'm done arching a new Library from a completed project with all the media in the library in one nice little bundle, THEN I go back to the original library (that I'm soon going to delete) and consolidate all the motion content into it's Library. Why do I do this, well, because I use lots of custom plugins for each project as well as commercial plugins. Over the years these don't get uninstalled or forgotten or whatever. But if you consolidate them into the library, you can then open the library and pull out the motion templates folder that will have them all nicely organized in a duplicate hierarchy that exists on your user folder. I do this merely for reference sake as only the effect used will be copied, not an entire template package. And anything from FXFactory or requiring serial numbers like stuff from CoreMelt of MotionVFX won't work without their accompanying serialized app. BUT, in the distant future I or the next person working or opening the project will have a handy folder as a guide to what to install or buy. I store this folder next to the archived library. Here's an example of what it looked like after a recent video series...



_______________________________________________________________________
http://BretFX.com FCPX Plugins & Templates for Editors & Motion Graphics Artists
Hang Tag http://bretfx.com/product/hang-tag
Overshoot Text http://bretfx.com/product/overshoot-text/
Outliner http://bretfx.com/product/outliner/
Clock Maker http://bretfx.com/product/bretfx-clock-maker/


Return to posts index


Ken Bennett
Re: Just Discovered Archiving Libraries Doesn't Work.
on Sep 13, 2018 at 9:09:53 pm

I don't currently use Motion. If I do I will keep this for reference.

Ken Bennett
Video Adventures
Capturing Your Life's Adventures!


Return to posts index

Bret Williams
Re: Just Discovered Archiving Libraries Doesn't Work.
on Sep 13, 2018 at 9:12:48 pm

It applies to all plugins and effects you might use in a project that aren't stock with the system.

FWIW the link between Motion and FCPX is the REAL killer feature.

_______________________________________________________________________
http://BretFX.com FCPX Plugins & Templates for Editors & Motion Graphics Artists
Hang Tag http://bretfx.com/product/hang-tag
Overshoot Text http://bretfx.com/product/overshoot-text/
Outliner http://bretfx.com/product/outliner/
Clock Maker http://bretfx.com/product/bretfx-clock-maker/


Return to posts index

Jeremy Garchow
Re: Just Discovered Archiving Libraries Doesn't Work.
on Sep 13, 2018 at 6:18:13 pm

[Ken Bennett] "The process: I delete rendered files, optimized media and proxy media to reduce Library file size"

What is the source footage? If you have rewrapped footage, you may have just deleted it (as FPCX does not store the original and optimized in these situations), and you would have to reimport from the camera originals.

Also, you are sure the media is missing, and you aren't seeing a missing filter icon?


Return to posts index


Ken Bennett
Re: Just Discovered Archiving Libraries Doesn't Work.
on Sep 13, 2018 at 8:37:45 pm

It is media that is missing and I do copy the original files into the Library so in the end it is self contained.

Ken Bennett
Video Adventures
Capturing Your Life's Adventures!


Return to posts index

Jeremy Garchow
Re: Just Discovered Archiving Libraries Doesn't Work.
on Sep 13, 2018 at 8:49:19 pm

[Ken Bennett] "It is media that is missing and I do copy the original files into the Library so in the end it is self contained."

There must be some sort of flaw in the process.

Perhaps the media you thought was the in the Library is not, and the external copy got deleted.

I always keep my media outside of the Library, otherwise it's simply too hard to see where it is.

When you consolidate media outside of the library, FCPX will simply copy it to a new location specified by the library. Perhaps the preferences weren't modified to import the media in to the library?


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]