APPLE FINAL CUT PRO: Apple Final Cut Pro X FCPX Debates FCP Legacy FCP Tutorials

Glitch in my timeline but not on the original file - I'm stuck.

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Erik Anderson
Glitch in my timeline but not on the original file - I'm stuck.
on Aug 16, 2018 at 5:44:42 am

Hello all,

If somebody could help me solve this problem, you'll be a hero to me.

There's a glitch in a certain video clip on my timeline. However, the glitch doesn't appear when I play the exact same clip in my event library. It also isn't present on the original file on my memory card.

I tried to fix it by deleting the clip from my external RAID hard drive, with the idea that I could reimport it, thereby fixing it.

It didn't work.

I got the red "file missing" clip in the library. When I tried to reimport it, it didn't fix it. I relinked the file, and the glitch is still there.

I found a post online that, if I'm understanding it correctly, suggests that I should delete the clip in my video cache. I'm not sure if that is the correct thing to do or whether that will screw up my project. I also don't know exactly where to find the cache.

I'm totally stuck.

Any advice or guidance would be greatly appreciated.

-Erik


Return to posts index

Jeff Kirkland
Re: Glitch in my timeline but not on the original file - I'm stuck.
on Aug 16, 2018 at 6:27:38 am

Have you used the option in the file menu to delete all render files? That's usually the cure for odd glitches and 100 times less likely to break the project than the things you've tried so far...

----
Jeff Kirkland | Video Producer & Cinematographer
Hobart, Tasmania | Twitter: @jeffkirkland


Return to posts index

Erik Anderson
Re: Glitch in my timeline but not on the original file - I'm stuck.
on Aug 16, 2018 at 7:48:16 am

Hi Jeff,

Thanks for the reply. I'll try it first thing in the morning. Quick questions before I do anything:
The
1) Which render files do I delete? the project? the library?

2) If I delete the render files, then what happens? Do I need to re-render everything?

(As you can probably tell, I have no idea what I'm doing. I'm a biologist.)


Return to posts index


Jeff Kirkland
Re: Glitch in my timeline but not on the original file - I'm stuck.
on Aug 16, 2018 at 10:57:59 am

Unless you tell it not to in the preferences, FCPX is constantly creating render files in the background. If they corrupt for some reason, you can get weird glitches in your playback.

I’m not in front of the app right now but under the file menu, you get to delete either unused render files or all render files. Choose all render files.

Once they’re deleted, your glitch should be fixed and FCPX will start recreating the render files in the background.

----
Jeff Kirkland | Video Producer & Cinematographer
Hobart, Tasmania | Twitter: @jeffkirkland


Return to posts index

Erik Anderson
Re: Glitch in my timeline but not on the original file - I'm stuck.
on Aug 18, 2018 at 2:18:43 am

Alright, here's the status report.

I selected the entire project, and then in the File menu, I chose 'Delete Generated Project Files".

This opened a window, which allowed me to check 'Delete render files', 'Delete optimized media', and 'Delete proxy media'.

I chose 'Delete render files'. Then Final Cut re-rendered my entire project.

The good news > The glitch is gone during that clip!

The bad news > There are two different glitches in other clips.

So, I deleted the render files again, and let it re-render.

Now the original glitch is gone, as well as the two others,......but two completely different glitches have formed.

Any recommendations? Should I keep this up until, hopefully, I get a glitch-free project?

Or could it possibly make the problem worse?

Thanks,
Erik


Return to posts index

Brett Sherman
Re: Glitch in my timeline but not on the original file - I'm stuck.
on Aug 21, 2018 at 12:22:39 am

One way to target individual clips is to just add the Color Board effect and make an imperceptible adjustment. That way you can go clip by clip.

But I would be concerned about why you're getting so many glitches. I'm thinking you may have a hard disk issue and your hard drive is corrupting the files.


Return to posts index


Erik Anderson
Re: Glitch in my timeline but not on the original file - I'm stuck.
on Aug 21, 2018 at 1:41:06 am

I didn't figure out the problem, but I found a work-around of sorts. I rerendered the project a couple more times until I found glitches in clips that I could easily replace with other shots of the same thing. It's not ideal because obviously, there are reasons I chose the original shots, but it worked.

I am using a two-bay RAID drive, and I found this discussion:
https://discussions.apple.com/thread/7172332

Not sure if that is what I'm dealing with.


Return to posts index

Brett Sherman
Re: Glitch in my timeline but not on the original file - I'm stuck.
on Aug 21, 2018 at 12:39:53 pm

There were some versions of FCP X which were more likely to glitch, I think that problem has been solved for awhile though. I think what you are looking at is some sort of data failure. Either it's not reading the file correctly. Or when it writes back to the drive, data is corrupted. I think the most likely explanation is your hard drive. Can you check the SMART status of your drives? Also, try moving your cache file to another drive and see if the same problem arises. The issue with RAID 0's is that if one of the drives is iffy, then the whole array is iffy. The other possible, but less likely, explanation is your RAM is not reliable.

It could also be a fluke with this particular project. But I'd want to test it some more before I'd be comfortable using that drive for another project.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]