APPLE FINAL CUT PRO: Apple Final Cut Pro X Creative Community Conversations FCP Legacy FCP Tutorials

FCP 7 Question (Yes I know, wrong forum)

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Bryan Hiltner
FCP 7 Question (Yes I know, wrong forum)
on Nov 14, 2016 at 9:00:50 pm

Hey everybody, I've got a weird issue with Final Cut Pro 7 and I couldn't find a forum to ask it in, so I thought I'd ask it here.

I recently directed a short film that was shot on the Sony FS700. The files are in 1080 resolution, not raw and not 4K or anything like that.

Most of the clips look great, but there's a weird glitch with some of the files. They only show up as a green screen when I freeze-frame them:

When I export the video clip from the FCP7 timeline, it comes out as blackness, no image visible.

When I press play in the timeline, the image reappears:

Not sure what to do! I tried running the problem clips through MPEG Streamclip, then tried running through Handbrake before then running through MPEG Streamclip. It does not seem to solve the problem.

What can I do? Any ideas? Besides the answer "Stop using FCP7", which I know is the truth... I just figure I'm gonna jump into the Adobe Premiere stuff from here since FCP seems to be heading a lame direction. Just don't want to learn the new software quite yet.

Return to posts index

Noah Kadner
Re: FCP 7 Question (Yes I know, wrong forum)
on Nov 14, 2016 at 11:04:27 pm

There is still an FCP Legacy forum-


FCP Exchange - FCPX Workshops
XinTwo - FCPX Training

Return to posts index

Claude Lyneis
Re: FCP 7 Question (Yes I know, wrong forum)
on Nov 15, 2016 at 3:28:09 am

Let's see. You post on the FCPX forum, call it lame and that implies the users are lame and you ask how to fix a FCP7 problem, when FCP7 is 6 years obsolete. Come on Man!

Return to posts index

Bryan Hiltner
Re: FCP 7 Question (Yes I know, wrong forum)
on Nov 15, 2016 at 3:38:36 am

Oh no... I didn't mean the users were lame, I meant I was lame for using outdated software and being lazy about upgrading. Maybe it's not lame... I was just afraid I was being lame.

I didn't realize that "Legacy" meant older versions of FCP; clearly that's where I should have been posting. Never posted here (or anywhere really) before, I just ran into a problem and was desperate for some help. Sorry everyone!

(Haven't updated to FCPX yet but am considering doing so)

Return to posts index

Patrick Donegan
Re: FCP 7 Question (Yes I know, wrong forum)
on Nov 15, 2016 at 10:31:16 am
Last Edited By Patrick Donegan on Nov 15, 2016 at 10:33:11 am

What are you attempting to edit in FCP 7 that cannot be edited in FCP X?

Yes, there is a whole new paradigm to learn - and once one learns it, one will see
that the other way is not truly "non-linear" the way connected clips are
in FCP X.

FCP X 10.2.3 - user since FCP 1.25
iMac mid 2011, MBA mid 2012
iPhone 4
HVX-200, Shure wireless mic
Miller Solo tripod

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2020 All Rights Reserved