APPLE FINAL CUT PRO: Apple Final Cut Pro X FCPX Debates FCP Legacy FCP Tutorials

Library wont load up from BackUp

COW Forums : Apple Final Cut Pro X Debates

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Jaime Mexia
Library wont load up from BackUp
on Mar 14, 2015 at 11:53:40 pm
Last Edited By Jaime Mexia on Mar 14, 2015 at 11:55:47 pm

I recently did a factory reset for my Macbook Pro.
I reinstalled Final Cut Pro, but I can't keep my projects...
I have placed all the folders of FCP from the folder "Movies" from the BackUp Drive, into my folder of "Movies".
When I open it, it tells me to choose a location to save the library in.
I click "OK", and a message comes up saying: You don’t have permission to save the file “.fcpcache.tmp” in the folder “Macintosh HD's projects and events”.

What did I do wrong, and what do I do?

I already added the permissions.
I just decided to do a full restore from my backup to my mac.
I now have another problem.
When I'm prompted to choose where to save my library, and I click "ok", a box comes up saying "'.fcpcache.tmp' couldn’t be removed."

Any ideas?

Return to posts index

Noah Kadner
Re: Library wont load up from BackUp
on Mar 15, 2015 at 2:31:59 am

Permissions are messed up. Try deleting and reinstalling FCPX and then repair permissions in Disk Utility.


Call Box Training

Return to posts index

Aindreas Gallagher
Re: Library wont load up from BackUp
on Mar 15, 2015 at 2:55:35 am

[Noah Kadner] "Permissions are messed up. Try deleting and reinstalling FCPX and then repair permissions in Disk Utility."

tasty. nothing like an application that lives and dies inside the mac windows dll shell. promo producer/editor.grading/motion graphics

Return to posts index

Jaime Mexia
Re: Library wont load up from BackUp
on Mar 15, 2015 at 3:52:22 am

Yeah, I've tried this method many times, and still no luck.
The only thing it lets me do is "Close Library"

Return to posts index

Bill Pendry
Re: Library wont load up from BackUp
on Mar 22, 2016 at 5:54:40 pm

I battled this problem for a user yesterday, and found a solution that may work for others. I'm posting here because this is one of the top Google results for this issue.

Our scenario was:
FCPX (10.2.3) libraries were stored on an external drive, and backed up with Time Machine to another external drive.
The video drive failed. We purchased a new drive and wanted to use it as the Time Machine drive, as it was now the largest drive.
We copied the TM backup to the new drive via the Finder.
We formatted the old TM drive to use as the new video drive, and copied the backup files to it via the Finder.

After doing this, we got the ".fcpcache.tmp couldn't be removed" error message for almost all FCPX libraries on the drive.
Restoring the folder that contained the libraries via the TM interface instead of via the Finder made most of the libraries work again, but not all.
Ownership settings looked correct for these files, but they couldn't be renamed or deleted without entering an administrator password, and they couldn't be moved from their locations, only copied.

Our method of moving the TM backups and files around via the Finder may have contributed to the problem, but I've seen reports of people having this issue when using TM in the typical way.

Here is the fix that worked for us:
Download BatChmod from
Open one of the affected files in BatChmod.
Uncheck "Change ownership and privileges". (I did this because ownership looked correct and I wanted to limit was I was changing, both to help identify the problem/solution and to avoid accidentally messing anything up. Leaving it checked would probably be fine.)
Check "Clear ACLs".
Click Apply.

After clearing the ACLs, the files would open in Final Cut Pro X without complaint, and renaming/deleting/moving worked correctly in the Finder as well.

Somehow the ACLs on these files were causing problems after being restored from the Time Machine backup, and removing them got rid of the problems. This can also be accomplished via the Terminal, but I prefer to work with GUI utilities when possible.

Hope this can help others with this issue!

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 All Rights Reserved