FORUMS: list search recent posts

External HD disconnected, files are missing, but still taking up space

COW Forums : Archiving and Back-Up

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Nels McLaughlin
External HD disconnected, files are missing, but still taking up space
on May 22, 2013 at 11:38:06 pm

I've spent an hour or so Googling my issue, and I've come across some that have similar issues, but not the same. Nothing I've tried so far has worked. Here's the issue...

I have an old Seagate drive that I havent trusted for years and was scared to turn on - the bad part about that is that it has some important files (pictures and videos) that I needed to get off and onto another, more reliable drive. I bought two new 2TB Seagate Backup Plus (yes, I know...I fixed a Seagate issue with another Seagate) hard drives to back everything up. I plugged my old Seagate to my iMac (running OSX 10.8.3) via USB 2.0, and my new Seagate using FW800. I reformatted the new drive, started the transfer, saw that it would take 4 or 5 hours, so I went to bed. I wake up, check the transfer, and find that the old drive had disconnected itself (told you it was unreliable) after transferring 5+ GBs out of 90GB. When I went to the old drive to try to re-start the transfer, I saw the old folders, but there were no files in them...but the files that were there originally, are still taking up half of the old drive (despite not showing up). I restarted the computer and found the same thing. I tried to repair disk with Disk Utility, but I got an error saying that DU "couldn't unmount the disk" (which usually means that there is a file still being used on the disk, which I can't find, and simply isnt true). Another thing I found out after trying to eject the old drive is that I have to force eject it, because the computer (or the drive) thinks that it is in use (which it's not).

Is this old drive just a really expensive paper-weight now? What can I do to make those invisible files that are still taking up half the space of the drive show up again?

I'm guessing I'm hosed and should be glad I got 5+ GB off it and move on. But my fingers are crossed!

Return to posts index

Vadim Carter
Re: External HD disconnected, files are missing, but still taking up space
on May 25, 2013 at 3:11:49 am

It looks like you have a dying drive that's developing bad sectors. You have a few options though:

1. If you absolutely must get your files back then you should not try to do anything else and contact a data recovery company (this is EXPENSIVE!!!)

2. Try installing and running SuperDuper. You might be able to clone your failing drive onto your new drive.

3. If that does not work, enlist a friend who is good with Linux and use ddrescue to attempt a sector-by-sector copy and recovery of your failing disk - This may take days, depending on how bad your disk drive is but you may end up recovering most of your data.

Lastly, please do not attempt to run any kind of filesystem repair utility on your failing drive - it will only corrupt it further.

Good Luck!

Lucid Technology, Inc. / 801 West Bay Dr. Suite 465 / Largo, FL 33770
"Enterprise Data Storage for Everyone!"
Ph.: 727-487-2430

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 All Rights Reserved