ADOBE PREMIERE PRO: Tutorials Forum Articles Creative Cloud Debate

Can't use my 1070 with Premiere Pro properly!

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Abhinav Joshua
Can't use my 1070 with Premiere Pro properly!
on Feb 8, 2017 at 4:07:12 pm

So I just installed a new Gigabyte GTX 1070 G1 Gaming graphics card in my PC. The CPU is i5 2nd generation. Before my graphics card, my 4k videos were playing back choppy in Adobe Premiere Pro CC 2017, now the realtime playback (without any effects) has slightly improved but it is still very choppy and it's harder to edit. I checked my CPU and GPU usage during playback. The CPU maxes out to 99℅ but only 900 MB is used from GPU out of 8 GB. Here are the things I've done:-
1. Updated Adobe Premiere Pro CC to the latest version.
2. Updated the NVdia Drivers tot the latest one and also unistalled ombaord graphic drivers.
3. Tried Audio Hardware - Input set to none.
4. Changed the video renderer to Software only from CUDA and other way round.
Please help me!


Return to posts index

Chris Wright
Re: Can't use my 1070 with Premiere Pro properly!
on Feb 8, 2017 at 4:19:52 pm

cuda only works on these effects. everything else is still cpu based.

https://helpx.adobe.com/premiere-pro/using/effects.html
https://blogs.adobe.com/creativecloud/scaling-in-premiere-pro-cs5/


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]