ADOBE PREMIERE PRO: Tutorials Forum Articles Creative Cloud Debate

Solids Won't Fade Properly

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Brent Taylor
Solids Won't Fade Properly
on Jan 31, 2017 at 6:38:04 pm

What's up. I've had this persistent bug in 2015 that I just can't seem to get rid of. Would really love it if anyone could help. Here's a picture that sums it all up.

11007_bugpicture2.jpg.zip

What we have here are three layers. In the middle of the timeline is our footage, where we have our host (covered by the rectangle for our example for anonymity) shot in front of a white background. I needed to move the host over for a graphic, so they've been slid to the left. To cover the leftover background space, I've made a white matte on the layer below. I was careful to make sure the whites matched.

Lastly, I have some black video above it with a crossfade, which should let us fade to black. However, as you can see (the preview window shows us halfway through the transition), we're seeing the problem. We get this big gutter on the right edge (where the matte meets the video background) instead.

The same thing happens no matter how I try to apply the transition. If I put a black matte with a crossfade, same deal. If I nest the footage and then fade, same deal. If I try other transitions (even linear wipes), they have the same crease as well. Adobe support talked to me for 2 hours before giving up.

I tried switching between CUDA and Mercury software only for the renderer. It's caused opacity problems for me in the past. while this does seem to give me different renders with opacity (which is another problem in and of itself) it doesn't seem to address this specific problem, or at least not consistently... when I first switched this setting I thought the problem was solved, but then it came back. It wasn't a simple matter of deleting previews with the new settings... tried that too.

The only thing that consistently works is nesting the footage with the background and then using the "Replace with After Effects Composition" command. Then things will fade properly. But that's a real pain if I need to make any other adjustments.

Any thoughts? This is making it really hard to get any work done. ☹

System specs below:
Premiere CC 2015.4

Windows 10
Intel i7-6800K CPU @ 3.4 GHx 3.40

RAM 32 GB
System Type 64-Bit operating system, x64-based processor

GPU
NVIDIA GeForce GTX 1060 6GB


Return to posts index

Brent Taylor
Re: Solids Won't Fade Properly
on Jan 31, 2017 at 8:22:20 pm

Update:

I tried importing only the relevant sequence into a new project in case something was wrong with the project file. After doing that, nested clips consistently fade properly, but putting black video and fading it over two layers in the sequence (as seen in the example) still give me the same problem.

I can see why I'd have this problem if I were trying to fade BOTH the video and the matte with their own crossfades. But fading something on top of both of them shouldn't have this effect (again, it stumped Adobe support too, so I'm not sure this is a case of "working as designed").

Anyhow, the nesting gave me a better workaround than relying on throwing it into an After Effects linked comp, but still not a great one... if I need to make adjustments to the video later it's still a problem.

I'm reluctant to even bring it up because I feel like nesting has occasionally worked in the past, only to stop working again just when I thought I had the problem solved...

That said, hopefully it sheds some more light on the situation? Still twisting in the wind on this one.


Return to posts index

Brent Taylor
Re: Solids Won't Fade Properly
on Jan 31, 2017 at 10:28:46 pm

Still more notes...

1) The problem that I thought nesting fixed failed to fix it in the actual render, even though it looked fine in the preview window.

2) Used a co-workers Mac and recreated original problem easily on an entirely new project.

3) Used the same co-worker's Mac to open the project that had looked fine on my computer until render. On this computer, the problem was immediately apparent in preview window and in the exports as well.

So far I'm leaning back to my original theory that the Mercury playback has something to do with it. The PC can't view projects with OpenCL / CUDA on, and the Macs can't view projects that I've sent over with Mercury software only.

However that doesn't explain all the issues I'm having. It's very strange.


Return to posts index


Dan Powers
Re: Solids Won't Fade Properly
on Feb 3, 2017 at 6:41:44 pm

Instead of using a crossfade, use an opacity keyframe. I am also getting that glitch when using masks and crossfades.

Go here.
http://www.adobe.com/products/wishform.html


Return to posts index

Brent Taylor
Re: Solids Won't Fade Properly
on Feb 3, 2017 at 10:26:33 pm

Hmm... nope. Using opacity keyframes is doing the same thing over here. ☹

That works on your end though, huh? I wonder if that gives us some kind of clue.


Return to posts index

Roger Averdahl
Re: Solids Won't Fade Properly
on Feb 4, 2017 at 2:33:05 pm

It seems to me that the size and/or the pixel aspect ratio of your layers have a different size and pixel aspect ratio than other layers and the timeline itself. Or, that the a layer with a matching size have been moved using the Position parameters. Or, that a layers opacity have been changed using the layers Opacity parameter.

Short story: There is a mismatch somewhere that causes this.


Return to posts index


Brent Taylor
Re: Solids Won't Fade Properly
on Feb 27, 2017 at 6:04:40 pm

Double checked the pixel aspect ratios and they're all the same.

The Position parameter was changed, yes. That was part of the point to begin with if you read what I was trying to do. But that shouldn't cause this problem. Fading a black layer over two white layers that look identical shouldn't cause a noticeable black bar to appear during the fade.


Return to posts index

Brent Taylor
Re: Solids Won't Fade Properly
on Feb 27, 2017 at 6:28:48 pm

I KNOW that Premiere is capable of doing this, because if I throw the white background and footage into a linked After Effects composition, everything works absolutely fine. That's just a real pain of a workaround... there's got to be another way to perform this very simple action.


Return to posts index

Chris Wright
Re: Solids Won't Fade Properly
on Feb 27, 2017 at 7:23:29 pm

under sequence, try disabling composite in linear


Return to posts index


Brent Taylor
Re: Solids Won't Fade Properly
on Feb 27, 2017 at 7:48:20 pm

Thanks Chris. Didn't know about that option.

It does affect the rate of the dissolve a little, so it might be relevant, but it doesn't fix the problem. :(


Return to posts index

Chris Wright
Re: Solids Won't Fade Properly
on Feb 27, 2017 at 8:00:23 pm
Last Edited By Chris Wright on Feb 27, 2017 at 8:02:27 pm

is the matte set to multiplied or straight alpha or none? those cause massive problems.
are you using adjustment layers?
are you using masks?
sequence - maximum quality checked?
delete work area and render files
delete media cache
Premiere Pro 11.0.2 update just came out and fixes a lot of stuff.


Return to posts index

Brent Taylor
Re: Solids Won't Fade Properly
on Mar 7, 2017 at 8:36:34 pm

"is the matte set to multiplied or straight alpha or none? those cause massive problems."

It's just set to "Normal" on the blending mode, but there's no mask or anything with it so changing this setting doesn't affect anything.

"are you using adjustment layers?"

No.

"are you using masks?"

No, none of these either.

"sequence - maximum quality checked?"

Tried it... doesn't seem to fix it. Messed around with all 3 of the checkboxes in that area... doesn't seem to affect the issue.

"Delete work area and render files"

No luck...

"delete media cache

No luck here, either...

"Premiere Pro 11.0.2 update just came out and fixes a lot of stuff."

Experimenting with 2017, it seems to be acting the same.


So far the only thing that makes a difference is toggling between GPU CUDA and Mercury Only for the previews. With GPU on, the problem disappears in some circumstances (nested footage with a transition is ok, but a layer on top of it still won't fade properly).

But in the render, the problem comes back in both cases, even if I specify GPU CUDA in AME.

Weird...


Return to posts index


Brent Taylor
Re: Solids Won't Fade Properly
on Mar 7, 2017 at 8:41:04 pm

Sorry, had the above backwards. Mercury looks ok in preview, not GPU. But both render incorrectly.


Return to posts index

Neal Broffman
Re: Solids Won't Fade Properly
on Mar 10, 2017 at 3:55:15 am

Brent, perhaps you did this when you tried to keyframe the opacity?
Delete your Black Video layer altogether.
Nest your video and background. Keyframe the opacity to zero.

Neal Broffman
One Production Place, Atlanta, GA
http://www.oneproductionplace.com
Current FIlm:
Help Us Find Sunil Tripathi
http://www.HelpUsFindSunilTripathi.com


Return to posts index

Brent Taylor
Re: Solids Won't Fade Properly
on Mar 10, 2017 at 2:34:58 pm

Thanks Neal.

So doing that is giving me the same bug as before.

If I have it set to CUDA, I can see it in the preview window.

If I have it set to Mercury only, your solution looks like it works, but still shows up in the final render (even if I chose Mercury only in AME before the export).

So strange that throwing this into After Effects is still the only thing that consistently works...

I wonder if it has something to do with my export settings?

I've just been using H.264 Match Source - High Bitrate for most of my tests. Just now I tried Quicktime and it's actually worse... instead of the bar showing up during the fade, you can see it the entire time.

Maybe someone can recommend a good export setting that lets me avoid this?


Return to posts index

Neal Broffman
Re: Solids Won't Fade Properly
on Mar 10, 2017 at 6:44:00 pm

As a workaround, instead of creating an AE comp you could export your composite with an extra second at the end and then import that clip into PP and just do the fade on that clip. While this does not answer why the problem is occurring it might be faster than the AE route and more permanent.

Neal Broffman
One Production Place, Atlanta, GA
http://www.oneproductionplace.com
Current FIlm:
Help Us Find Sunil Tripathi
http://www.HelpUsFindSunilTripathi.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]