ADOBE PREMIERE PRO: Tutorials Forum Articles Creative Cloud Debate

Choppy playback and performance issues new Macbook Pro 15" 2016

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Felix Swensson
Choppy playback and performance issues new Macbook Pro 15" 2016
on Dec 13, 2016 at 11:17:47 am

Hi!

Just got my new late 15" 2016 macbook pro model (2,7 Ghz i7, 16GB ram, Radeon Pro 460 4GB) which should be enough for my demands. However, I am experiencing some performance issues. I am getting very slow and choppy playback in my project.

I am working on XAVC-I 25P UHD material from a Sony FS7, something that worked just fine with my late 2012 version iMac.

I am reading the files from the internal SSD so disk performance shouldn't be the problem. I have also switched between Open CL and Metal no difference. I have also tried different versions of Premiere (2017 & 2015.3), same problem.

When working the same files in Resolve things are very smooth so it seems there's a problem with Premiere.

Any advice of things I could try?

Best,
Felix


Return to posts index

Ole Kristiansen
Re: Choppy playback and performance issues new Macbook Pro 15" 2016
on Dec 13, 2016 at 2:48:42 pm

Maybe you have to read this:

https://forums.creativecow.net/thread/3/969947


Return to posts index

Felix Swensson
Re: Choppy playback and performance issues new Macbook Pro 15" 2016
on Dec 13, 2016 at 3:03:22 pm

Hi. Thank you for your reply.

Looked through that post but there's was nothing there to help me. Transcoding to Prores is not something I want to do (and it shouldn't be necessary). I tried rewrapping one of the files but that made it unreadable to Premiere.


Return to posts index


Tero Ahlfors
Re: Choppy playback and performance issues new Macbook Pro 15" 2016
on Dec 13, 2016 at 4:11:15 pm

[Felix Swensson] "Transcoding to Prores is not something I want to do (and it shouldn't be necessary)"

Transcoding to a format that runs well on your computer is necessary if you want to have a format that runs well on your computer. If that's an unnacceptable step in your workflow for you then you need to buy a beefier computer.


Return to posts index

Felix Swensson
Re: Choppy playback and performance issues new Macbook Pro 15" 2016
on Dec 13, 2016 at 4:29:01 pm

Yeah but it is strange that editing in XAVC-I worked well on my old iMac and barely at all on my new macbook. Except for that my new computer is faster on everything else.

Guess I might have to work in Prores in the meantime and hopefully I will find a solution to this problem soon :/


Return to posts index

Chris Wright
Re: Choppy playback and performance issues new Macbook Pro 15" 2016
on Dec 14, 2016 at 6:33:17 am

there's loads of things you can check to make sure your getting good playback performance:

Since a lot of people have been having problems with smooth playback,
here's my total "make everything playback smoother" solutions chart.

1. un-ticked "Enable accelerated Intel h.264 decoding" in preferences/media tab and closed extra premiere panels-hidden?
2. add premiere in NVidia Control Panel as an application for discrete gpu
3. power option-maximum performance

4. Make Sure The Composite Preview During Trim is Turned Off and also make sure your Reference Monitor is Also Closed it Will Help Solve the Choppy Playback
5. Set Preferences : > Audio hardware > Default Input: to None

12. disable "High Quality Playback" setting in the monitor wrench menu improves gpu
13. disable mercury transmit
15. freezing up on mac permission issue
http://blogs.adobe.com/kevinmonahan/2014/09/10/premiere-pro-cc-freezing-on-.....

19. Changed Audio Hardware from MME to ASIO.(lower level audio driver for lower latency)
20. Limited Premiere's RAM allocation to 32Gb if you have 64GB
21. In task manager, set affinity to utilize only 16 cores for PP (unfortunately, this setting does not hold on re-launch)
23. in bios, disable Intel Speedstep.
24. disable C1E - in the bios, power settings,change to performance.

25.
- go to CTRL+F12 and find these settings: top left change to debug database view
- DisableSpeculativePrefetching - set this from false to true
- ImporterMXF.ReadBlockSizeinKB: default is 1024. Experiment with this.. I'm trying 2048 with good results
- CodeProfiler - set to true
- GPU.EnableGOPFormats: set from false to true
- Player.MainMaxOutstandingAheadofPlayback=3 ://10 default
- Player.MainMaxQueuedFrames=10 :// 300 default

The above two can make a difference. Higher values if you're working 60P rates.


26. set audio to 44.1 in hardware and premiere
audio pref - disable play audio while scrubbing
disable maintain pitch
audio hardware latency 200ms

disable sequence composite linear color
sequence audio settings 32000hz
sequence settings preview file 1920x1080 1/2 size video frame size 3840x2160 then 1/2 size playback

27. in monitor, pull markers together so there's less tick marks per inch, the playback marker will go offscreen while playing back.


Return to posts index


Felix Swensson
Re: Choppy playback and performance issues new Macbook Pro 15" 2016
on Dec 14, 2016 at 9:36:01 am

Thank you for your help!

I tried everything in your guide (at least the settings available on OS X) but I still have the same problem. The problems are not specific to clips in the timeline. Just playing clips in the source-player (not sure what it's called) isn't working well enough. It's not terrible but it always gets choppy after a few seconds. Impossible to work like this.

I guess I will have to transcode to Prores for this project and hope software updates will make things better in the future :/


Return to posts index

Felix Swensson
Re: Choppy playback and performance issues new Macbook Pro 15" 2016
on Dec 14, 2016 at 9:40:16 am

Btw, I know this has been discussed before. But for the camera I'm using Sony FS7 would you transcode to ProRes 422, 422 HQ or 444? How much will it matter?

Thank you!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]