ADOBE PREMIERE PRO: Tutorials Forum Articles Creative Cloud Debate

Creative Sound Blaster Z with Premiere CC... anyone got it working?

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
David PayneCreative Sound Blaster Z with Premiere CC... anyone got it working?
by on Aug 1, 2016 at 6:46:18 pm

I was sick of using ASIO4ALL with my onboard audio because of various problems outside of premiere so I bought the first known to work fine sound card that I could find. The Sound Blaster Z. Well. It doesn't work.

I uninstalled ASIO4ALL and installed all of the up to date creative drivers and now when I select ASIO in premiere audio hardware options I get:

"The device settings could not be applied because the following error occurred:

The device could not be opened.

The last valid settings will be used"


I have tried adobe support and they have told me they can't help. My old Sound Blaster Audigy 2 worked fine without ASIO4ALL however I've upgraded my pc and it will not fit in my new motherboard.

Any advice greatly received. Please dont tell me how bad the sound card is. I'm not a pro sound editor and I saw online it has been very popular among premiere users so something is clearly not right with my setup.


Return to posts index

Gary HuffRe: Creative Sound Blaster Z with Premiere CC... anyone got it working?
by on Aug 1, 2016 at 7:44:47 pm

[David Payne] " Please dont tell me how bad the sound card is. I'm not a pro sound editor and I saw online it has been very popular among premiere users so something is clearly not right with my setup."

Except when I do a search online for your card, I only see Premiere users having problem after problem. So perhaps the choice of the Sound Blaster Z was not a good one for what you want to do.


Return to posts index

David PayneRe: Creative Sound Blaster Z with Premiere CC... anyone got it working?
by on Aug 2, 2016 at 10:22:01 pm

All I remember is seeing more than one person say they have it and it works fine. It seemed very commonly available so I thought drivers etc would be easy to find. In the end, it just doesnt do anything for my pc so it is going to be returned tomorrow.

Do you have a different sub £100 card that you would recommend?


Return to posts index


Gary HuffRe: Creative Sound Blaster Z with Premiere CC... anyone got it working?
by on Aug 3, 2016 at 4:35:22 am

[David Payne] "Do you have a different sub £100 card that you would recommend?"

There are not a lot of options, certainly not at that price range. If you can find an ASUS XONAR card, I would look into that, but I cannot guarantee how well that will work. My experience with Windows and Premiere is always on the built-in sound device.


Return to posts index

David PayneRe: Creative Sound Blaster Z with Premiere CC... anyone got it working?
by on Aug 4, 2016 at 8:13:33 pm

I've ordered one, let's see what headaches that one gives me! Thanks


Return to posts index

David PayneRe: Creative Sound Blaster Z with Premiere CC... anyone got it working?
by on Aug 5, 2016 at 12:56:07 pm

thank you Gary I love the xonar, exactly what I wanted! Simple 5.1 without ASIO4ALL


Return to posts index


Gary HuffRe: Creative Sound Blaster Z with Premiere CC... anyone got it working?
by on Aug 6, 2016 at 2:11:16 pm

[David Payne] "hank you Gary I love the xonar, exactly what I wanted! "

Glad that worked for you! And thanks for following up so that I can store that little nugget away for the next person who needs a solution too.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 CreativeCOW.net All Rights Reserved
[TOP]