ADOBE PREMIERE PRO: Tutorials Forum Articles Creative Cloud Debate

Can't Get Rid of Black Bars

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
James AubleCan't Get Rid of Black Bars
by on Jun 7, 2016 at 8:28:54 am

Hi there,

Forgive me for my newbie nature of my question, but I'm having trouble removing the black bars from a simple videos that I'm importing, rotating, and then exporting. I've tried changing the frame size upon creating the sequence and also scaling the video up to fill the preview window but everything I leaves me with black bars still. Despite my searches I havn't discovered what it is i'm doing wrong. I simply want to end up with a 1920x1080 version of my source which is the same but vertical instead of horizontal like I want. Here are some screenshots of my project and the resultant video:

My project: http://i.imgur.com/JhXpGqN.png

Exported Video: http://i.imgur.com/is12wWh.png

Any help would be much appreciated.


Return to posts index

Oki PienandoroRe: Can't Get Rid of Black Bars
by on Jun 7, 2016 at 11:58:05 am

From the looks of it, looks like you rotate the image 270 degree, is that correct ?
You didn't give us info what the original source files frame size (before you rotate to landscape).

So i'm assuming the source files doesn't conform with 16:9 ratio or 9:16 ratio when you record it on portrait mode.
No matter what you do it will still have the black bar since it doesn't conform with that ratio.
So you either need to enlarge/shrink the video manually using effects tabs (Don't use "Scale Frame to Frame Size),
which means a portion of your image will be lost due cropping.

Are you really sure the black bar still exits, even after you enlarge/shrink the video?
Because there's a chance your VLC didn't properly show the video (let say, you inadvertently set the VLC to render a 50% frame size).
In other word, the black bar is not exist, but because VLC wrongly configured it scaled down the video, so it may look like you still have a black bar.

The only way to test this is to re-import the output to premiere again.

------------------------------------------
Sorry for the english, not native speaker.


Return to posts index

Jeff PuleraRe: Can't Get Rid of Black Bars
by on Jun 7, 2016 at 6:01:06 pm

From looking at your sample images, the source video clip is of a lower resolution than the Sequence being used in Premiere. For instance, maybe the Sequence is set to 1080p (1920x1080) but the source clip is 720p (1280x720) and that is where the black surround comes from. Think of a Sequence as a picture frame and the video clip as the photo. If the frame is too large, you will have empty space surrounding the photo in the frame.

You must either use a smaller Sequence like 720p, or scale up the video to fill the frame before exporting. Whatever you see in the Program monitor window at upper right is what you will get when exporting, so the result should not be a surprise.

Normally, to get the proper Sequence size, one could right-click the clip in the Project Bin and select New Sequence from Clip, however it is possible that if the clip was shot with the camera rotated that you could end up with a Sequence that might be 720x1280 rather than 1280x720, so you may have to configure that manually by creating a New Sequence and choosing the appropriate preset. Pay attention to frame rate to match the source as well as resolution.

Not that it should make any difference in the end, but you can Rotate counter-clockwise, so you could just use -90 rather than spinning all the way around at 270 degrees to correct the orientation of the image.

Thanks

Jeff Pulera
Safe Harbor Computers


Return to posts index


Ann BensRe: Can't Get Rid of Black Bars
by on Jun 7, 2016 at 9:04:25 pm

You cannot have 1920x1080 as the clip is 720x1280 in portrait.
So set up a sequence that is 1280x720 (this is landscape)
Drop the clip on the timeline (dont change settings if it askes and turn off Default set to FRame Size in the Preferences)
Rotate clip -90 degrees.

-----------------------------------------------
Adobe Certified Expert Premiere Pro CS6/CC
Adobe Community Professional


Return to posts index

James AubleRe: Can't Get Rid of Black Bars
by on Jun 8, 2016 at 2:52:24 am

Thanks for your replies and also that my aspect ratio of my source file wasn't 1920x1080 like I thought. After setting up a sequence at 1280x720 I now am able to scale my video without cropping or black bars. I'm still not sure why the file properties in windows show an incorrect aspect ratio for the source file that led me to my initial mistake. Here's a screencap of the source file properties:



If I can't rely on this to determine the resolution of my source file what would be the best alternative to do so?


Return to posts index

James AubleRe: Can't Get Rid of Black Bars
by on Jun 8, 2016 at 3:06:13 am

Just a follow-up, within Premiere the source file also also shows as 1920x1080 by clicking on the imported clip properties. Interestingly enough, I create a 1920x1080 sequence and imported both that original problematic clip and another clip (captured with a different mobile phone) and the latter shows up as expected, but the original file in question shows up as if it were 1280x720. I can't explain this, maybe someone else can shed some light on this for me.


Return to posts index


Oki PienandoroRe: Can't Get Rid of Black Bars
by on Jun 8, 2016 at 12:01:06 pm

Maybe because it's a fake 1920x1080. The image is 1280x720 but the camera export them (with black bar) as compensation to 1920x1080.
We can't know for sure unless you share the problematic file..

------------------------------------------
Sorry for the english, not native speaker.


Return to posts index

Oki PienandoroRe: Can't Get Rid of Black Bars
by on Jun 8, 2016 at 12:29:07 pm

Follow up for my previous reply.
If you're not convenient to share the files publicly, perhaps we can use this workaround.

Download the image template below that i made for you, it's a frame template ranging from 4K through 720.
10169_frametemplate.png.zip

Now make a new sequence based on that frame, which mean you will have a 4K sequence.


Now drop the problematic file on top of that image.
Make sure the frame is on 4K sequence don't resize the files, or your footage.

Post your result (screen cap the program panel).
This way we can actually see the border (including the "fake" black border) if there's any, in that problematic files.

This is the only way i can think of, to detect your frame border without you sharing the file itself.

------------------------------------------
Sorry for the english, not native speaker.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 CreativeCOW.net All Rights Reserved
[TOP]