ADOBE PREMIERE PRO: Tutorials Forum Articles Podcasts Basics Forum Creative Cloud Debate

Premiere Pro CC playback choppy during editing

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Brian RicePremiere Pro CC playback choppy during editing
by on Mar 7, 2016 at 6:52:28 pm

@Okay, here are my computer's specs right off the bat since I know that's the FIRST question anybody will have for me:

15" MacBook Pro, mid-2014
2.5 GHz Intel Core i7
16GB RAM
NVIDIA GeForce GT 750M 2048 MB (with Cuda)
512 GB SSD (of which I have about 80 GB available)
OS X El Capitan (10.11.3)
Adobe CC 2015

Alright, so I think that covers the essentials. If I sound terse in the message, it's because it's 3:30am and I've been wasting the last four hours trying to figure out this thing. Well, actually more since I discovered it earlier this week.

Basically, Premiere is VERY choppy and is skipping frames during playback of any file that has any effect applied. Even black and white, which I'd think would be simple to playboack. If there's no effect applied to the clip and is just the video as shot right out of the camera, it's actually fine. But any effect and it skips and is really makes editing difficult if not impossible. THIS IS SOMETHING THAT WASN'T HAPPENING BEFORE. I've tried dropping down to Premiere CC 2015 v1 and CC2014, but while those are marginally better, they're still not performing right. I've tried switching to OpenCL and Software on the Mercury rendering thing but no difference. The two remotely close culprits would be the latest update of Premiere CC 2015.2 and/or my recent installing of the Cuda driver (and as I said above, I do have an NVIDIA card). Unfortunately I can't seem to figure out how to delete Cuda from my computer despite seeing suggestions about deleting files from my computer; didn't seem to work as I still see it in the software.

I'm sure I'm forgetting something about what I'm doing, but this is frankly ridiculous, and from other threads I've looked up online, I'm definitely not the only one with the issue. I am at the point where I am VERY SERIOUSLY considering switching to Final Cut Pro X, though I'd hate to lose the integration with After Effects (which seems fine in its performance). Earlier this week I updated a short video by dropping in some new clips to replace the old clips in spots, something which you'd THINK would be really quick, but with all the slow, choppy playback, it took me over four hours. Enough.

Please advise. Thanks.


Return to posts index

Tero AhlforsRe: Premiere Pro CC playback choppy during editing
by on Mar 7, 2016 at 7:18:45 pm

What kind of footage and where's the media located?


Return to posts index

Brian RiceRe: Premiere Pro CC playback choppy during editing
by on Mar 8, 2016 at 12:17:09 am

4K footage from a GoPro DJI Inspire 1 drone, and dSLR footage (Nikon D800, D600, and D750). Media is located on my laptop's solid state drive. But the important thing to understand is that all of this was fine until the cc 2015.2 update in January.


Return to posts index


Chris WrightRe: Premiere Pro CC playback choppy during editing
by on Mar 7, 2016 at 8:42:03 pm
Last Edited By Chris Wright on Mar 7, 2016 at 8:57:56 pm

Since a lot of people have been having problems with smooth playback,
here's my total "make everything playback smoother" solutions chart.


1. you can try rolling back to an earlier video driver

"old drivers from 2014 work better (performance-wise) than the current ones"
https://forums.adobe.com/message/8447565#8447565

2. add premiere in NVidia Control Panel as an application for discrete gpu
3. deleting all preferences/clean media cache files/also in Roaming folder
4. Make Sure The Composite Preview During Trim is Turned Off and also make sure your Reference Monitor is Also Closed it Will Help Solve the Choppy Playback
5. Set Preferences : > Audio hardware > Default Input: to None
6. install latest updates for Adobe and your gfx card or roll back driver if using older gfx card
7. is your gfx card supported for cuda? By default, CUDA needs at least 768M video RAM
go to:file-project settings-video renderer-is it greyed out?
8. download a monitoring program that tells you what is maxed out, your disk cache speed, cpu, gpu, RAM, etc. That should narrow down the problem.
9. "Why am I getting yellow and red lines running through my footage on pause?"
render the timeline (press the Enter key on your keyboard) so that yellow lines along the top of the timeline turn green
https://forums.adobe.com/thread/1979303
10. toggling off the High Dynamic Range setting and LUT's in the setting menu of the Lumetri Color panel improves gpu
11. if you're using AVHD footage, the cpu could be maxing out. try transcoding with handbrake to quicktime png to test
12. disable "High Quality Playback" setting in the monitor wrench menu improves gpu
13. disable mercury transmit
15. freezing up on mac permission issue
http://blogs.adobe.com/kevinmonahan/2014/09/10/premiere-pro-cc-freezing-on-...
16. disable/remove soundcard if all else fails
17. CC 2014 playback is better, well maybe a little...


Return to posts index

Brian RiceRe: Premiere Pro CC playback choppy during editing
by on Mar 8, 2016 at 12:15:07 am

Thanks. What I did that seems to have gotten it to work "normally" again was to rollback to CC 2015.0, as well as managing to remove the Cuda driver from my computer. I hadn't worked on any video since December, but the update to 2015.2 was late January, and I didn't resume video work until last week when I discovered the issues I discussed (I also added the Cuda driver last month). For the time being, I think I'm content to leave it at that.


Return to posts index

Brian RiceRe: Premiere Pro CC playback choppy during editing
by on Mar 8, 2016 at 12:26:07 am

Also, I've looked at the Preferences/Audio Hardware and I don't see an option for Default Input, so I can't even switch that to None...


Return to posts index


Brian RiceRe: Premiere Pro CC playback choppy during editing
by on Mar 17, 2016 at 6:05:50 pm

Just another update:

I did go back to the current version, 9.2, and it seemed fine with an old project that had previously been problematic with playback, but when I began a new project, the choppiness returned, albeit with 4k footage. Now, before you say it's probably about my system settings etc...I subsequently rolled back to 9.0, and it's all fine, now. I also reinstalled the latest Cuda driver (7.5.25) and it's not causing any problems with 9.0 (and when I had it removed, 9.2 was still problematic).

So, the gist of all this is that, for some reason, Premiere CC 2015 9.2 has something buggy that's causing it to not run properly on my system. I'll wait and see how 9.3 turns out before upgrading again.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 CreativeCOW.net All Rights Reserved
[TOP]