ADOBE PREMIERE PRO: Tutorials Forum Articles Creative Cloud Debate

Field Artifacts

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Michael GoldbergField Artifacts
by on Dec 29, 2015 at 5:23:45 pm

Hi,
I have been getting some noticeable field artifacts when exporting out of adobe premiere CC. I have some footage shot at 1080i, and I'm simply editing shots down to smaller shots and exporting to H264. The original shots out of the camera are AVCHD. When I look at the footage in windows media player, It looks perfect. I'm not seeing any artifacts, or interlacing hints at all. I'm bringing that into premiere into a progressive sequence, and exporting as progressive. I'm also interpreting the footage as progressive. I've also tried every combination of interpreting the footage as UF in an UF sequence etc. I have yet to get an export from Premiere that does not have noticeable field artifacts. I'm attaching 2 stills of a grabbed still frame from windows media player. I can stop the footage on various spots, and in the original I see not interlacing, and in the premiere processed clip, I see interlacing whenever there's motion. It's been driving me nuts, thinking maybe the footage isn't 1080i, but either way, if I don't do any deinterlacing, and don't do any scaling in Premiere, I should be able to export the same clip. I thought maybe it was due to the export format (H264), but I tried other formats (quicktime Animation compressor) with the same results. I've also gotten the same results in media encoder. It's a small interlacing artifact that I wouldn't even worry about, it's just that when I look at the original, it always looks slightly cleaner. Any thoughts on the processing that is or isn't happening once I bring the clip into Premiere?

Maybe too much holiday drinking?

Mike







Return to posts index

Vince BecquiotRe: Field Artifacts
by on Dec 29, 2015 at 7:03:33 pm
Last Edited By Vince Becquiot on Dec 29, 2015 at 7:06:35 pm

Hi Michael,

Is your footage interlaced or PSF? As an alternative, try leaving it interpreted as interlaced (Upper first) and see how that looks.

Also this looks more like something you would see in frame blending than interlacing artifacts. Can you double check that the frame rates are consistent?

Vince Becquiot

Indigo Live | Kaptis Media

San Francisco Bay Area


Return to posts index

Michael GoldbergRe: Field Artifacts
by on Dec 30, 2015 at 4:08:57 pm

Hi Vince,
Yep the frame rates are consistent. I've tried interpreting the footage as progressive, making the timeline progressive, and rendering progressive, still noticeable lines. I've tried interpreting as UF with timeline as UF etc. The bottom line is I'm seeing more noticeable interlacing lines in every option.
If anyone wants to take a look at the original shot, I've uploaded it here:

View Link: http://clientshare.ccfv.com
Project Name: MG Temp2
Username: gold2
Password: goldtemp2
filename: 00980.MTS

Note: For best results, download file to your local hard drive.



Return to posts index


jerry wiseRe: Field Artifacts
by on Dec 30, 2015 at 6:38:05 pm

i don't see anything wrong with your footage. you shot in interlaced. on my system i can look at the scene where a leaf falls center screen and on my computer monitor looking at "program" and select "150%" instead of "fit" you will see scan lines. on my 1080i broadcast monitor i see field jitter. it's normal to see that since you shot interlaced. on my tech monitor which is a progressive monitor i see no jitter but i see scan lines. in your timeline you could right click on your clip and select "field options" and then select "flicker removal"
i did that and on all my monitors the field jitter and scan lines are gone. give it a try.


Return to posts index

Jeff PuleraRe: Field Artifacts
by on Dec 30, 2015 at 7:53:05 pm

Hi Jerry,

I've been working with 1080i footage exclusively for about 8 years now. I edit in a 1080i sequence and when exporting to H.264 (as 1080p or 720p), the footage gets deinterlaced and comes out progressive and I've never seen any issues in the final product.

I think you're perhaps trying too hard with interpreting and all that, and maybe even causing the issue...just edit natively in 1080i as Vince brought up.

Thanks

Jeff Pulera
Safe Harbor Computers


Return to posts index

Michael GoldbergRe: Field Artifacts
by on Dec 31, 2015 at 4:05:35 am

Thanks Jeff,
I am probably just looking at this too closely.
a Few questions for you -
When you edit natively at 1080i, I assume you're footage is being interpreted as Upper Field first, and you're timeline is also set to Upper Field First?

When export progressive, effectively you're discarding a field, or interpreting the second field with some type of blending, correct?
Are you not noticeing a slight quality loss?

This has given me the best results, but I do see a slight degradation (which might just be inevitable if I want to go out Progressive), when I export this way. It's very slight I admit, but was just trying to get the best results.

Thanks,
Mike



Return to posts index


Michael GoldbergRe: Field Artifacts
by on Dec 31, 2015 at 4:01:57 am

Thanks Jerry,
I can get the footage to display nicely in Premiere. Generally just displaying 1 field rather than both gives me the correct look. My concern is that I'm slightly degrading the footage once I export.
What I was hoping was to not deinterlace on export, and have the footage look exactly the same when I play the final H264 in WMP or in VLC. I'm seeing a slight degradation.
When I deinterlace, and then export as progressive, this looks pretty good, but I can notice a degradation in quality which is inevitable since the second field is either being thrown away, or interpolated at that point. I'll keep experimenting though.

Mike



Return to posts index

Michael GoldbergRe: Field Artifacts
by on Jan 3, 2016 at 3:11:07 pm

Happy New Year,
I just wanted to update this for anyone interested.
I think it was an H264 issue I was seeing.
Since the original footage was .MTS, I decided to try to output to the same format (or at least comparable). I used MPEG2 Blue Ray set to transport stream, when outputting this from a 1080i sequence with everything set at default UF - I got the exact same footage as the input, at the same file size.
I went back to H264, and found that if I set the bitrate up to the maximum (300), I got pretty much the same result. Only difference was the file size was huge. At lower bit rates to H264, I was still getting a little bit of artifacts (probably acceptable). I decided to output progressive, and that also gave me very good results and similar file size to the original. All in all, a good test.
The original problems seemed to be due to too small of a bit rate with H264. Thanks for the suggestions though.

Mike



Return to posts index

Tero AhlforsRe: Field Artifacts
by on Jan 4, 2016 at 9:25:03 am

[Michael Goldberg] "I went back to H264, and found that if I set the bitrate up to the maximum (300), I got pretty much the same result. Only difference was the file size was huge."

Yep. When you're compressing with H264 you're losing detail in a multitude of ways. Fast movement won't look as sharp if you're limited by the bitrate or keyframes. Either the file is huge and looks reaaaaaally good or it's small and looks a bit worse compared to the original.


Return to posts index


Jeff PuleraRe: Field Artifacts
by on Jan 4, 2016 at 3:02:57 pm

Hi Mike,

Keep in mind that computer displays are not interlaced, and therefore most folks that would try to play your 1080i export clip may see interlacing issues. That is, unless they know to go into the menu of their player software and set up deinterlacing options properly, which 99.7% of the public have no clue about. So if sharing the files with others/posting online, then you'll likely want 1080p or 720p, not 1080i as a deliverable.

Thanks

Jeff Pulera
Safe Harbor Computers


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 CreativeCOW.net All Rights Reserved
[TOP]