ADOBE PREMIERE PRO: Tutorials Forum Articles Creative Cloud Debate

Premiere cs6 works slow on windows 8.1

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Vid OgrisPremiere cs6 works slow on windows 8.1
by on Mar 28, 2015 at 2:58:36 pm

Hello

After installing windows 8.1 on my machine I can see that premiere is working slow. As slow I mean when importing files, creating new items, bins, sequences it has a couple of seconds of "lag". On the same machine with windows 7 these was not happening.

Any suggestions?

My machine is
Dell XPS,
Windows 8.1
8GB ram
Intel i7 2,2 GHz
SSD Intel 500 series 250GB
GeForce GT 540M


Return to posts index

walter biscardiRe: Premiere cs6 works slow on windows 8.1
by on Mar 28, 2015 at 5:49:52 pm

My guess is that CS6 is not optimized for Windows 8.1 like the new CC versions are. Moving forward in an OS is not always the best thing when running older software, especially software that's older than 3 years which is where I think CS6 is now.

Walter Biscardi, Jr.
Editor, Colorist, Director, Writer, Consultant, Author, Chef.
HD Post and Production
Biscardi Creative Media

Craft and Career Advice & Training from real Working Creative Professionals

Blog Twitter Facebook


Return to posts index

Al BergsteinRe: Premiere cs6 works slow on windows 8.1
by on Mar 29, 2015 at 11:42:02 am

Did you do a clean install or "over the top" of the old one?

Al


Return to posts index


Pooja ChauhanRe: Premiere cs6 works slow on windows 8.1
by on May 25, 2015 at 11:51:00 pm
Last Edited By Pooja Chauhan on May 25, 2015 at 11:53:38 pm

Windows 8.1 was released in Oct 2013 & CC I believe was released in 2014 so I believe CS 6 might have been thoroughly tested. Does anyone else have an issue with 8.1 & CS6 (especially Adobe Premiere Pro & After Effects), would like to know as I am considering Windows 8.1 too.. Thanks!


Return to posts index

Al BergsteinRe: Premiere cs6 works slow on windows 8.1
by on May 26, 2015 at 12:40:34 am

according to wikipedia:
The first new versions made only for the Creative Cloud were released on June 17, 2013.
That jives with my memory of getting it, as I was on the first wave. I ran it on Windows 7 64 bit at the time with no issues. I never upgraded to 8.1.

I would roll back your install to Windows 7. Especially if you did an *over the top* install and didn't start with a fresh OS on a reformatted drive. In the future, when you do this kind of upgrade, I would recommend getting a new drive, and starting from scratch. That way you can always fall back gracefully.

My personal opinion is that 8 GBs RAM was minimalistic for Adobe products, especially CC, on Win7. You can use your Windows resource manager to watch the utilization of RAM as you open and run any application. That's how I found out that my problems in W7 were due to a lack of RAM. Once I upgraded to 16GBs my Adobe performance issues vanished.

Did you happen to do any other changes between W7/CS6 and W8.1/CC? Like start working with 4k files on a GoPro or GH4? That is my current performance hog. I think I we need a new i8 processor with 4-4GB graphics cards to make it run smooth. Oh, right, that's a MacPro. (just kidding).

Al


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]