ADOBE PREMIERE PRO: Tutorials Forum Articles Podcasts Basics Forum Creative Cloud Debate

Video glitch from a7s MTS files

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
David ParkeVideo glitch from a7s MTS files
by on Feb 27, 2015 at 2:35:52 am

AVCHD footage worked great in Premiere 5.5, went to CC (2014) on another system just fine, wanted to set up an editor on CC (Legacy) and all the footage has a super weird glitch almost like there's a codec or video card issue but I haven't seen this on this particular system.

Any thoughts? It's not pressing which is nice but it worries me enough for future projects shot on this camera. Thanks!

David Parke

Return to posts index

Sara AxelssonRe: Video glitch from a7s MTS files
by on Feb 27, 2015 at 10:05:37 am


When I worked with A7s material I converted the material to ProRes422 HQ so I didn't work with it nativly. However I couldn't do the conversion in DaVinci Resovle because the codec wasn't a "regular" h.264. I needed video and audio and the audio wouldn't convert for some reason....
Maybe it's something to do with that? Strange that it worked just fine in Premiere 5.5...

If you don't have a ton of material I would recommend to convert it to ProRes422.


Return to posts index

Jeff PuleraRe: Video glitch from a7s MTS files
by on Feb 27, 2015 at 2:56:00 pm

Hi David,

Please make sure to follow this workflow with Premiere - copy entire SD card content to a folder on your hard drive, exclude nothing. Just copy the card in whole. Then in Premiere, import using "Media Browser" rather than "File > Import" method.

Hope this helps


Jeff Pulera
Safe Harbor Computers

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved