ADOBE PREMIERE PRO: Tutorials Forum Articles Creative Cloud Debate

Massive Lagging and issues with Premiere Pro

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Danny Yourd
Massive Lagging and issues with Premiere Pro
on Jan 11, 2015 at 2:20:28 am

For the last year we have been in post on our feature documentary. We have roughly 15TB of footage that is all stored on a raid coming into our edit suite via fibre (I don't know much of the technical information about it other than it's trustworthy and works for the other suites in our facility). We're in the final stretch and locking edit February 1. But the issues we're experiencing are making it very difficult to advance and fine tune the edit.

Over the last month or two performance with Premiere has been getting worse and worse. We are experience lag in actions when editing. It could be as simple as moving the mouse, clicking or copy/paste which can result in freezing or lag where we have to wait a few seconds or minutes for the program to catch up with itself.

We've been trying to figure out what is going on and if we can do anything to eliminate these issues. We have removed all cache files. We have eliminated any unnecessary or old sequences from our project file.

I will note that our project file is massive. It's currently about 1.15gb in size. Our sequence is a little hairy also. Not sure if this could be causing issues, but it hasn't in the past. See image below.

Running latest version of Adobe Premiere CC 2014.

Mac Pro
OSX Version 10.9.5
Processor: 2.7 GHz 12-Core Intel Xeon E5
Memory: 64GB 1867 MHz DDR3

Return to posts index

Peter Garaway
Re: Massive Lagging and issues with Premiere Pro
on Jan 23, 2015 at 7:33:02 pm

Hi Danny,

I have some suggestions that will hopefully be helpful to you. Very impressive timeline btw.

- Disable“Show Duplicate Frame Markers”
- Disable“Display out of sync indicators for unlinked clips”
- Disable “Maintain Audio Pitch While Scrubbing”
- Disable“Show FX Badges”
- Turning off Audio Waveforms
- Turn off Multicam view
- Disable Transmit
- Make sure your Network/Shared Storage not set to "full duplex”

A few additional questions. Do you have the following in your project?

- Warp Stabilizer on a lot of clips?
- Multiband Compressor on a lot of clips?
- Is there a lot of Dynamic Link clips?
- Do you have multiple Media Browsers open?

I hope one or some of these suggestions get you guys going. Please let us know how it goes.


Peter Garaway
Premiere Pro

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 All Rights Reserved