ADOBE PREMIERE PRO: Tutorials Forum Articles Podcasts Basics Forum Creative Cloud Debate

Premiere Pro & FCPX - OS Requirement Question....

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Tom LaughlinPremiere Pro & FCPX - OS Requirement Question....
by on Dec 17, 2014 at 6:08:59 pm

Been in Premiere Pro now for a while, with several projects still living in PPCC 7.2.2, waiting on a break in between clients to I can update and switch to PPCC 8.0.1. Now, I've got a new client that wants his stuff cut in FCPX, since he already has the first few clips cut in his project, but has no time to keep editing on this project, so he's passing it on to me.

Question: I'm running OS 10.7.5, and I'm still editing 'other' client projects in in PPCC 7.2.2, so now I'm getting ready to download and start editing for first time in FCPX, but FCPX requires 10.9.2 or higher. If I update my current OS from 10.7.5 to 10.9.2, will some apps act weird or not work at all? I'm ok to wait a few more weeks to edit in FCPX, but updating the actual OS, that's making me a little nervous, especially with client work being edited in PPCC 7.2.2.

Tom Laughlin
Digital Chop House
Salt Lake City, Utah

Return to posts index

Noah KadnerRe: Premiere Pro & FCPX - OS Requirement Question....
by on Dec 17, 2014 at 11:38:38 pm

You should create a Yosemite boot partition and then you have nothing to risk. Definitely some apps have conflicts with Yosemite so it's worth doing. It's pretty easy:


Call Box Training

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved