ADOBE PREMIERE PRO: Tutorials Forum Articles Podcasts Basics Forum Creative Cloud Debate

Slow response Premiere when building (longer) sequence.

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Willem KortSlow response Premiere when building (longer) sequence.
by on Dec 15, 2014 at 4:29:52 pm


We're a company working on corporatie videos and television documentaries. Six months ago, we started working with Adobe Premiere, saying goodbye to FCP7, after experiencing many crashes, connection errors, etc.

Premiere seemed a stable program to us, being capable of working with mixed formats/codecs, from GoPro h264 to Prores4444, avc100, etc. But this was only done at that moment for short corporate videos.

Last week we've decided to have a day of testing for a new docu series we will start working on next month, shot mostly on AVC INTRA 100 and very quickly we've noticed that Premiere started getting sluggish when working on a longer sequence (1 - 1.5 hour).

When we started duplicating this sequence, Premiere would start to react worse and worse, playback taking 5-10 sec, same with skipping through the sequence. Beachballs, superslow response, etc. All this was happening with one sequence opened and the others closed.

We've tested this on two of our sets:

1 Mac Pro Nehalem:

Quad-Core Intel Xeon 2.26 GHz

Proccessors: 2

Cores: 8

Memory: 12 GB

Blackmagic Decklink HD Pro (Dual Link)


OS: 10.9

2 Hackintosh:

8-Core Intel Xeon
3.2 GHz

Processors: 1

Cores: 8

Memory: 64 GB

Blackmagic Decklink HD Extreme 3D+

NVIDIA GeForce GTX 680

OS: 10.9

Both have SSD drives with OS/Applications, Media is stored on a QNAP NAS (60TB) with 10GB ethernet connection.

I've noticed when I remove audio clips from a sequence, things speed up amazingly.

Anyone any idea what can be the reason of this weak performance?

I understand that our hardware config is not the newest one, but it seems such a big difference in performance between the projects we've been working on so far on Premiere and this new test project.

If we need to give more info about config, setup, please let me know.


Return to posts index

Nils WelterRe: Slow response Premiere when building (longer) sequence.
by on Dec 15, 2014 at 6:23:53 pm

You Can shut off "show out of sync indicators for unlinked clips" in preferences. And shut off "show duplicate frame markers" in The timeline wrench menu.
This should Speed things up when Working with long Timelines with many clips inside.

Nils Welter
Adobe Certified Instructor - Premiere Pro

CBC Cologne Broadcasting Center
Cologne, Germany

Return to posts index

Andrew KimeryRe: Slow response Premiere when building (longer) sequence.
by on Dec 15, 2014 at 7:29:48 pm


Do you have a lot of multicam too? I ran into a similar problems and the solution for me was to stop having so many duplicate sequences. I dupe sequences a lot when I make revisions but instead of duping sequences I changed to duping the project. So instead of having one project with a ton of old cuts in it I would dupe the project each morning and clear out the Old Cuts folder so each project would only contain cuts from that day.

I feel like this got fixed in CC2014 though. Which version are you running?

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2016 All Rights Reserved