ADOBE PREMIERE PRO: Tutorials Forum Articles Creative Cloud Debate

R3D 8K Premiere to Resolve problems, plus a bonus head scratcher! (long post)

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Jeff Markgraf
R3D 8K Premiere to Resolve problems, plus a bonus head scratcher! (long post)
on Nov 7, 2019 at 9:17:46 pm

Hope the big brains on the COW can help out. (N.B. not my project, not my screw up...helping a co-worker.). A combination of Premiere and Resolve questions, so I'm looking for you Premiere-Resolve workflow guys to help out.

R3D 8K footage all on a Jellyfish server in the correct, original folders & file structure. Editor working on CC 2017 on 2013 MacPro. He cuts a bunch of spots that are to be sent via XML or AAF to color grade in Resolve. Colorist (also the DP) has a copy of the files. Should be no problems. Wrong.

Our fearless Editor did not import the files correctly. He dragged the individual files from each RDC folder into his bins. So instead of one clip (say A005_C012...) he now has each part of the spanned clip as an individual clip (A005_A012..._001, ..._002, etc.). He also added scene/take info to the file names in the bins (which may be a bad idea if the project is going to another platform?)

Additional info: the 8k R3D footage is 23.98 fps, edited into an HD 29.97 sequence for broadcast. We do this all the time with the 4k stuff we shoot, and no problems either in FCPX (our house standard) or Premiere (this guy who refuses to learn FCP and one other).

Right out of the gate, the first sequence doesn't relink correctly in Resolve. Several clips link to obviously wrong time code, randomly off one or two seconds, in some cases pointing to time code earlier or later than what is on the linked clip. Some clips won't link to anything at all. Colorist thinks it could be because of 23.98 source in a 29.97 sequence. So I get involved and convert the sequences to 23.98 and send new AAFs. Still no joy. Total hit or miss. Some link, some don't. Some correct time code, some not.

Then I find out about the incorrect file import issue. And that the editor actually deleted some parts of the spanned clips from his bins - the parts "he didn't need." And I discovered the renamed clips. Oy, vey!

Clearly the editor screwed the pooch on this thing from the get go, but I think we've managed to straighten out some of the mess.

Questions:

Does Resolve have a problem when the source material and sequence are different frame rates? Or is there a problem when interpreting an XML or AAF from a Premiere sequence with those different frame rates?

Does renaming a clip in the Premiere bin cause Resolve to lose track of the clip? I know Avid relies on the unique clip ID when it ingests & transcodes a clip, but does Premiere give each imported clip a similar unique ID in its database when it is imported (leaving original file in place) so that the bin name doesn't matter?


Now, here's the bonus head scratcher:

As I tried to troubleshoot this on my system, I opened the original Premiere project in CC2018, which copied and updated his project. To my surprise, I found that a bunch of the source clips would not link. When I attempted to relink them, I got an error message. What I found in each case, was that at least one part of the master spanned clip file on the server was not being recognized as a valid R3D file. In some cases, the _001 piece showed the generic Mac OS curled paper GIF indicating an unknown file, while the _002 piece showed the expected thumbnail. Sometimes it was the other way around. Sometimes one of three parts of the spanned file was bad. Sometimes two out of fiver parts were bad.

Huh.

In these cases, the offline clip in the timeline match framed to timecode in a portion of the clip that would have been in the "bad" part of the spanned clip, which was not able to be displayed in Premiere.

Furthermore - and far more worrisome - those problem R3D files also showed up as corrupted in Finder. FCPX would not load these clips, nor would RedCineX Pro, because one or more parts of the spanned clip was not recognized.

Something corrupted parts of these clips. My first thought was that old XMP changing the metadata business from a ways back. But I checked all the systems with Premiere loaded and the "write XMP" thing in preferences is unchecked. Weirdly, the only system that can read those files is the original editor, who is the only one on CC2017.

I had to retransfer those folders from the shoot archive drive onto a different drive location in order get my Premiere 2018 or my FCPX or my Mac Finder to see the full, uncorrupted files. They simply won't recognize the files on the server anymore.

I'm stumped and more than a little concerned. And so far things seem to point at Premiere 2017, but I don't understand how or why.

Thanks for making this far. Any thoughts at all are welcome.

Jeff M.


Return to posts index

Chris Wright
Re: R3D 8K Premiere to Resolve problems, plus a bonus head scratcher! (long post)
on Nov 8, 2019 at 5:07:15 am

you have to use media browser in premiere to import red clips. you can't drag them from locations as premiere parses the duplicate files and spanned clips correctly. also, resolve and premiere don't do speed changes so you have to flatten out any effects, transitions in the XML prior to sending over(simple dissolves may survive). The easiest way to do this is to duplicate the sequence and move all video to track 1.

You have to render and replace any speed changes. Since premiere and resolve handle interpreting framerate differently, you will have to flatten mixed framerates out too. As mixed framerates and sub-clips won't make it out from XML, you will have to consolidate them with project manager as seen here.

in Preferences: Media, you can check 'Write XMP ID to files on import'. This will tag each piece of media with a unique ID, which Premiere can keep track of. Then it will always recognize duplicate clips. (you have to do this before you do anything)

proxies files are case sensitive(dumb, I know) audio channels have to match for proxies to link.


Return to posts index

Jeff Markgraf
Re: R3D 8K Premiere to Resolve problems, plus a bonus head scratcher! (long post)
on Nov 8, 2019 at 8:01:31 pm

Hi Chris. Thanks for responding. All good advice, most of which I'm already familiar with.

I've explained the proper import procedure to the editor. I wish he'd asked before starting! Oh well.

The sequences are very simple. No speed changes or effects. All source is the same frame rate: 23.98. No proxies used. This should have been a really simple exercise. The only unusual part for us was the R3D 8k source files. It seems clear to me his not having imported the spanned files correctly was the primary source of the problems getting the sequences to our colorist.

But I'm confused about the XMP thing. The Write XMP ID box is unchecked by default. You're saying it should be on? I remember there used to be an issue where that feature changed the original files enough that they wouldn't relink in FCP (we are an FCPX house), but I guess that was fixed.

Is anyone aware of any way Premiere could have changed the metadata of parts of the R3D files in such a way that they're no longer seen as valid files? This is the piece of this puzzle that really has me concerned, as I now have a number of master source files that no longer work. I will delete them from the server and reload them from the archive drive, but this really makes my head hurt.


Return to posts index


Oliver Peters
Re: R3D 8K Premiere to Resolve problems, plus a bonus head scratcher! (long post)
on Nov 9, 2019 at 12:24:02 am

Hmm... When things like that are badly handled from the beginning, it's often hard to fix it any other way than a manual fix. Yes, Media Browser is the way to bring RED clips into Premiere. You don't need XMP in this situation, if everything were done correctly.

On the Resolve side, make sure you bring all of the RED files into your Media Pool first and then import the XML as a timeline and point to the files in your Media Pool. Generally this works, however, the name differences of the spanned clips may cause problems. Your Resolve project rate should still be 29.97 to match the Premiere sequence. When you import the RED clips, do not change the frame rate.

Did the editor do anything to "interpret" the clips in Premiere. Such as change the clip's base frame rate? If so, Resolve will end up syncing to the wrong part of the clip. I've had similar situations from Avid projects and the simplest fix was to over-cut the clips by TC (the old linear editing way) and go clip-by-clip like that until you are done.

- Oliver

Oliver Peters - oliverpeters.com


Return to posts index

greg janza
Re: R3D 8K Premiere to Resolve problems, plus a bonus head scratcher! (long post)
on Nov 10, 2019 at 6:55:23 pm

I think Oliver's idea of re-cutting the clips into a new timeline might be your best option. Create a new project and import all of the R3D files correctly through the media browser. Then re-create your original timeline in your new project. Obviously this is a pain in the ass on the front end but your workflow will be infinitely easier as you roundtrip to and from Resolve.

https://www.linkedin.com/in/tmprods
tallmanproductions.net


Return to posts index

Eric Santiago
Re: R3D 8K Premiere to Resolve problems, plus a bonus head scratcher! (long post)
on Nov 12, 2019 at 1:21:01 pm

Thinking without my hat here but what about searching clips via timecode?
Is that an option in Resolve?
I honestly don't know since this is the first I've heard of anyone importing spanned files before.
But I can now see how this can accidentally happen :(


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]