FORUMS: list search recent posts

Red Epic footage on my mid-2010 iMac

COW Forums : RED Camera

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Zak Scott
Red Epic footage on my mid-2010 iMac
on Jun 18, 2016 at 6:21:06 pm

Hey there,

First time editing with 4K.

I need to edit Red Epic footage on mid-2010 iMac i3. It will be a 15 minute narrative film without any graphics.

My specs are:
Processor: 3.2 GHz Intel Core i3
Memory: 4 GB 1333 MHz DDR3
Graphics: ATI Radeon HD 5670 512 MB

I haven't received the footage yet, but when I do, the client will be sitting with me.

Will it even play? How likely is it that I am, well, screwed?

I plan on upgrading my RAM from 4 GB to 16 GB.

Is it worth the money to do that, or should I start financing a new computer?


Return to posts index

Eric Santiago
Re: Red Epic footage on my mid-2010 iMac
on Jun 23, 2016 at 12:28:36 pm

Depends on your NLE.

You could create proxies from REDCINE or let the NLE do that for you.

Ive edited 4K full features on a 2008 MPB Uni with 8GB RAM.

Not finished on that but still managed to survive.

I used Avid and FCPX on that one and both let you create workable formats (DNxHD and ProRes).

Current movie project had the Director edit his whole film in Premiere using a laptop and iMac.
He had no issues since I created Proxies for him out of REDCINE.
The re-connection isnt hard if you maintain naming.
We finished mostly out of RESOLVE.


Return to posts index

Stephen Smith
Re: Red Epic footage on my mid-2010 iMac
on Mar 22, 2017 at 8:24:12 pm

Zak,

How did things work out for you? What program are you editing in?

Stephen Smith

Utah Video Productions

Check out my Vimeo page


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]