MAGIX VEGAS: MAGIX Vegas Tutorials MAGIX Vegas Forum Articles Black Magic Design Forum AJA Xena Forum

Renderd video loses quality in VEGAS pro 17

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Jimmie Brady
Renderd video loses quality in VEGAS pro 17
on Jan 12, 2020 at 6:27:16 pm

I've encounterd a problem which i cannot find a fix for and is hard to describe. Bassicly i was changing the dynamic ram preview in my prefrences so i could prerender my videos better. But when i renderd the video to a .mp4 it actully lost quality. I know that it's not the same quality because i took a screenshot of the original file and the render and the two compared look very different. The renderd video was a little blury and harder to see. So how i tried this is how i tried to fix it: I disabled the resample on every clip and in project settings. I changed my dynamic ram preview multiple times and i also tried rendering it in different formats i even resetted my Vegas pro but nothing worked. That's why i came here to see if any of you might know the fix. I would appreciate any help.


Renderd video in VEGAS screenshot: http://www.mediafire.com/convkey/95eb/f28vzjdcs5dcwm2zg.jpg

Original file screenshot: http://www.mediafire.com/convkey/9aad/0nl8m5lb0adf6ehzg.jpg


Return to posts index

Steve Rhoden
Re: Renderd video loses quality in VEGAS pro 17
on Jan 13, 2020 at 12:55:42 am

You first need to make sure your render settings are set to render out the highest quality first! You have not mentioned anything here as to what your render settings are etc. If you are rendering out and your finished file size is small, that is compression, and the more your video is compressed the more quality it loses. At first i thought your problem was resampling, but you said you disabled it completely.
Then your issue only is the rendering format and its settings that you are choosing!

Steve Rhoden (Cow Leader)
Film Maker & VFX Artist.
Owner of Filmex Creative Media.
Samples of my Work and Company can be seen here:
http://www.facebook.com/FilmexCreativeMedia


Return to posts index

Jimmie Brady
Re: Renderd video loses quality in VEGAS pro 17
on Jan 13, 2020 at 12:36:13 pm

Well that's just the thing my render settings are 1080p 60fps and i set everything to best. I tried just rendering the entire video and i compared the original to the renderd video. What i saw is that the renderd video is 50mb and the original file is 156mb! So you're right it is being compressed. Although i don't know how to can fix it. Something i also noticed is that when i max out the preview settings in VEGAS pro and click the fullscreen button, it looks like the original file without any quality loss.

My project properties screenshot: http://www.mediafire.com/convkey/2dd9/kjeqjk8l7ynke32zg.jpg

my render settings screenshot: http://www.mediafire.com/convkey/0989/ttraaft40tnfd6qzg.jpg


Return to posts index


Francois Pénzes
Re: Renderd video loses quality in VEGAS pro 17
on Jan 13, 2020 at 9:03:51 pm

Hi Jimmie

What version of Vegas are you using ?

Also, I notice that your computer's language is in Dutch, shouldn't your project be set at 25 or 50 PAL instead of NTSC?

Also try to render with Field order: None (progressive scan) and let us know if you get the same results.

Cheers !

PC Win 10 Pro 64-bit 16gb
Ryzen 9 3900X 12 Core 4.60GHz
Radeon RX 5700 XT
Cameras: Canon XF305 + Canon XH-A1
Vegas Pro 16, User since Vegas 3.0

''When the cutting stops, the editing begins...''


Return to posts index

Jimmie Brady
Re: Renderd video loses quality in VEGAS pro 17
on Jan 14, 2020 at 7:04:57 am

I tried every setting of the field order and nothing seemed to change except a little bit of size. I'm using VEGAS Pro 17. Also the PAL one has a lower frame rate why should i pick that one?


Return to posts index

Francois Pénzes
Re: Renderd video loses quality in VEGAS pro 17
on Jan 14, 2020 at 11:36:14 am

Hi Jimmie

Things can get weird when going to or from different Field Orders. There are so many variables that can come into play. One needs to establish specification lineage. Is the original material produced interlaced or progressive, frame rate, media file format, etc . Same with settings of capture of material. At every step of the process, were the same parameters kept. Also, keep in mind that there is quality loss every time something is recorded and/or rendered.

I know that this lecture is not what you are looking for but with the (fairly) recent democratization of video capture and editing, most of the ''Why and How'' was lost with the automation of the processes. Everything will work and come out great as long as you don't deviate from ''The
Standard
'' (if there ever was one...) That leads to potential problems along the way. I'm just saying that you have to take everything into account. One seemingly negligible thing can throw you a curve ball.

It would be nice to have a single button that would fix everything. Unfortunately, sometime you end up with problematic material along the way.

What is the end use of your material ?

Cheers !

PC Win 10 Pro 64-bit 16gb
Ryzen 9 3900X 12 Core 4.60GHz
Radeon RX 5700 XT
Cameras: Canon XF305 + Canon XH-A1
Vegas Pro 16, User since Vegas 3.0

''When the cutting stops, the editing begins...''


Return to posts index


Jimmie Brady
Re: Renderd video loses quality in VEGAS pro 17
on Jan 14, 2020 at 1:40:13 pm

Thanks for the lecture ☺ that button would be amazing haha. I make gaming montages with Vegas i also edit for other peaple which i actully make money with that's why a good quality is crucial for me. I do have some good news. I tried another render setting ("MEGIX HEVC/AAC MP4 " > "Internet 1080p 59.92 fps (NVIDIA NVENC)") and that actully improved the quality still not as good as the original file but it's much better. This proves that it is the render settings but i sitll don't know what i need to change to fix it.


Return to posts index

Ole Kristiansen
Re: Renderd video loses quality in VEGAS pro 17
on Jan 15, 2020 at 1:25:58 pm

Hi Jimmie !

The first thing I would look at is specs on your footage - otherwise you may not know what values ​​to use when rendering your finished movie!

Do you know the program: Media Info ?

Best,
Ole


Return to posts index

Jimmie Brady
Re: Renderd video loses quality in VEGAS pro 17
on Jan 15, 2020 at 4:27:50 pm

The specs of the original file and of the renderd video are both 1920x1080 and 59.92 fps. And no i don't know that software. Is it the one where it recognizes resolution when making a screenshot of a video?


Return to posts index


Ole Kristiansen
Re: Renderd video loses quality in VEGAS pro 17
on Jan 15, 2020 at 5:29:34 pm

"The specs of the original file and of the renderd video are both 1920x1080 and 59.92 fps"

You need the full specs of your recordings !

Here you can see all the information from one of my recordings with my Panasonic GH5 from Mediainfo !



Return to posts index


Jimmie Brady
Re: Renderd video loses quality in VEGAS pro 17
on Jan 16, 2020 at 2:40:07 pm

I installed the software and took screenshots of the specs. I noticed that the bitrate and stream size are extremly different. I couldn't find a stream size option in Vegas but i did find a bit rate option. So i maxed the bit rate and renderd it. The renderd video was a little bit bigger (10mb) and it barrely made a difference.

Screenshot original file specs: http://www.mediafire.com/convkey/ed6b/iyigtszloakbb57zg.jpg?size_id=a

Screenshot renderd video specs: http://www.mediafire.com/convkey/fd97/jg4ubxpw11panhkzg.jpg?size_id=a


Return to posts index

Bruce Brent
Re: Renderd video loses quality in VEGAS pro 17
on Jan 16, 2020 at 3:02:21 pm

Jimmie, I see what your problem is.....you've rendered HEVC which is highly compressed. Try Main Concept/Internet 1080p. Click "Customize," click "two pass," then click the "Project" tab and click "Video render quality" and click "best."

Let us know how that turned out with Media Fire results as in the previous post.


Return to posts index

Jimmie Brady
Re: Renderd video loses quality in VEGAS pro 17
on Jan 16, 2020 at 4:53:53 pm
Last Edited By Jimmie Brady on Jan 16, 2020 at 4:58:31 pm

Hi Bruce. I tried going to Main Concept MPEG-1 and MPEG-2 but neither of them had "Internet 1080p" and there was no improvement when i renderd a video in MPEG-2.

A screenshot: http://www.mediafire.com/convkey/a3e3/za36dtzumn55nsgzg.jpg


Return to posts index

Ole Kristiansen
Re: Renderd video loses quality in VEGAS pro 17
on Jan 16, 2020 at 6:19:52 pm

I can see that the Overall bit rate is 40.5 Mb/s for your recordings -
so try using: Magix AVC / AAC MP4 template - set Maximum (bps) 40,000,000 and Average (bps) 30,000,000 - and test if the quality gets better!

Main Concept / Internet 1080p mp4, is legacy in 16, and 17 -
you can get it as follows - but don't think mainconcept - not updated for many years - should not be better than Magix AVC / AAC!

MainConcept AVC/AAC doesn't appear as a render format in Vegas Pro 16.0

https://forums.creativecow.net/docs/forums/post.php?forumid=24&postid=10226...

Maybe This Video can give you a few tips to get better quality!

Best & Fastest Sony Vegas Pro 15 Render Settings for 60 FPS







Return to posts index

Jimmie Brady
Re: Renderd video loses quality in VEGAS pro 17
on Jan 17, 2020 at 12:20:24 pm

It works! The quality is the same as the original file. I want to thank everybody for helping me with this issue and have a good day.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2020 CreativeCOW.net All Rights Reserved
[TOP]