MAGIX VEGAS: MAGIX Vegas Tutorials MAGIX Vegas Forum Articles Black Magic Design Forum AJA Xena Forum

Vegas Pro 16 absolutely CHUGS when working with MJPEG video

COW Forums : VEGAS Pro

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Michael Hoogasian
Vegas Pro 16 absolutely CHUGS when working with MJPEG video
on Jun 17, 2019 at 1:30:39 am
Last Edited By Michael Hoogasian on Jun 17, 2019 at 1:31:20 am

So I have a short 1080p30 MJPEG clip that I tried to use in a project in Vegas Pro 16, and everything came a to GRINDING halt... I'm not really sure why, given that the clip plays back just fine in Windows Media Player.... The problem persists even with a fresh project. System is Win7 x64 with 24GB of RAM and VP16 build 424. Help?

Here's the output from MediaInfo:

General
Complete name : E:\my_video.avi
Format : AVI
Format/Info : Audio Video Interleave
File size : 313 MiB
Duration : 45 s 567 ms
Overall bit rate : 57.5 Mb/s

Video
ID : 0
Format : JPEG
Codec ID : MJPG
Duration : 45 s 567 ms
Bit rate : 57.4 Mb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate : 30.000 FPS
Color space : YUV
Chroma subsampling : 4:2:2
Bit depth : 8 bits
Scan type : Progressive
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.922
Stream size : 312 MiB (100%)

Audio
ID : 1
Format : MPEG Audio
Format version : Version 1
Format profile : Layer 2
Codec ID : 50
Duration : 45 s 531 ms
Bit rate mode : Constant
Bit rate : 160 kb/s
Channel(s) : 2 channels
Sampling rate : 44.1 kHz
Compression mode : Lossy
Stream size : 889 KiB (0%)
Alignment : Aligned on interleaves
Interleave, duration : 26 ms (0.78 video frame)


Return to posts index

Graham Bernard
Re: Vegas Pro 16 absolutely CHUGS when working with MJPEG video
on Jun 17, 2019 at 5:00:31 am

[Michael Hoogasian] "The problem persists even with a fresh project. ....... Help?"
Hi Michael. I need to ask: Have you Matched your Project Settings in “Project Settings” to the Media? This will ensure VegasPro is best optimised for dealing with that Media.

* Grazie

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX60HS Bridge


Return to posts index

Michael Hoogasian
Re: Vegas Pro 16 absolutely CHUGS when working with MJPEG video
on Jun 17, 2019 at 1:48:28 pm
Last Edited By Michael Hoogasian on Jun 17, 2019 at 1:49:47 pm

Yep. Vegas correctly detects it as 1920x1080 progressive at 30.00FPS but it still becomes unusably slow, frequently hanging 30+ seconds. Also FWIW, I noticed while it's hanging, my disk indicator light is on, but not solid on. Rather it looks like it's being PWMed at high speed. I wonder if Vegas is trying to read the MJPEG file one frame at a time and thus issuing a bunch of system calls to the disk rather than reading it all at once with just one system call?


Return to posts index


Graham Bernard
Re: Vegas Pro 16 absolutely CHUGS when working with MJPEG video
on Jun 17, 2019 at 2:19:58 pm

[Michael Hoogasian] "I wonder if Vegas is trying to read the MJPEG file one frame at a time and thus issuing a bunch of system calls to the disk rather than reading it all at once with just one system call?"
Does sound plausible. Something is definitely choking Vegas.

* Grazie

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX60HS Bridge


Return to posts index

George Dean
Re: Vegas Pro 16 absolutely CHUGS when working with MJPEG video
on Jun 18, 2019 at 4:58:59 pm

Hi Michael,

Vegas will read/load the file into memory and for the amount of memory you have and the small file size, I would say the entire file is in memory. Once loaded, Vegas will use the appropriate codec to decode the file. It needs to do this frame by frame and sometimes, depending on the codec it will need to look forward several frames and then go back to assemble the contents of several frames into one before progressing to display the next frame. You probably know all this.

Where is it choking, when loading the file, or during playback? Is the wait time during building the audio wave? After you start a new project and load, waiting until finished, close that project and open the project for the second time, it load time shorter and/or playback smoother?

What has changed in your system, OS, etc.?

If you have been using Vegas Pro 16 for a while, try a full reset of the program and delete the cached application data.

This may be one of those problems you are going to need to add a lot of information about your workflow and system for members to help.

Best Regards......George


Return to posts index

Michael Hoogasian
Re: Vegas Pro 16 absolutely CHUGS when working with MJPEG video
on Jun 18, 2019 at 9:13:28 pm

[George Dean] "Where is it choking, when loading the file, or during playback? Is the wait time during building the audio wave? After you start a new project and load, waiting until finished, close that project and open the project for the second time, it load time shorter and/or playback smoother?"

Even after waiting for it to load the file, it still chokes even when doing something as simple as moving to the next frame in the preview window. Out of curiosity, after waiting for it to load in a clean project, I rendered it to 10Mbps H.264, and Vegas has no issue working with the transcoded file...

[George Dean] "What has changed in your system, OS, etc.?"

I'm not entirely sure what you mean by that. Changed since I installed VP16? Nothing that I can think of really.

[George Dean] "If you have been using Vegas Pro 16 for a while, try a full reset of the program and delete the cached application data."

To ensure this was not the issue, I tried using the clip in my old Movie Studio 12, and it suffers the exact same symptoms.

[George Dean] "This may be one of those problems you are going to need to add a lot of information about your workflow and system for members to help."

The only other things that I can really think to add that would be relevant are: I have GPU accel turned off (as you recommended I do in a previous thread which solved the red screen issue) and that this particular MJPEG file was created by guvcview in Linux.


Return to posts index


Graham Bernard
Re: Vegas Pro 16 absolutely CHUGS when working with MJPEG video
on Jun 19, 2019 at 5:01:17 am

[Michael Hoogasian] " this particular MJPEG file was created by guvcview in Linux."
Hi Michael, I believe we are getting somewhere and now need more information:
1] Supply SCREENGRAB of your Project Settings.

2] Supply MediaInfo of that MJPEG.
MediaInfo is a remarkable FREEBIE s/w that analyses your Media. Download MediaInfo from here .

In the meantime you could try setting Preview Quality to PREVIEW DRAFT. Vegas could be making Proxy files of that MJPEG.

* Grazie

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX60HS Bridge


Return to posts index

George Dean
Re: Vegas Pro 16 absolutely CHUGS when working with MJPEG video
on Jun 19, 2019 at 1:15:11 pm

Michael, sounds like the mystery is solved.....

Movie Studio has the same problem, and VP16 doesn't have an issue with the converted file.

So, it appears it is your source media.

If you have more of these source media files, you may want to consider using something like the free app Handbrake to transcode/convert your source, as Handbrake may not have the same problem loading and may be much faster converting.

Best Regards......George


Return to posts index

Michael Hoogasian
Re: Vegas Pro 16 absolutely CHUGS when working with MJPEG video
on Jun 19, 2019 at 3:20:45 pm

[George Dean] "Movie Studio has the same problem, and VP16 doesn't have an issue with the converted file. So, it appears it is your source media."

That may be the case, however, that would seem to implicate there is a longstanding bug in how Vegas is interpreting the file. I suppose I should file a bug report with MAGIX. Would you be interested in seeing if you can reproduce the issue if I uploaded a smaller sample clip to Google Drive?


Return to posts index


George Dean
Re: Vegas Pro 16 absolutely CHUGS when working with MJPEG video
on Jun 19, 2019 at 5:38:27 pm

Hi Michael,

Yes, upload a sample here and I will be happy to look at it and compare loading and processing times.

Also, if our theory is correct, that the source file is the issue, it may not be a bug with Vegas. All the NLE's that I am familiar with have some restrictions on the source media they will handle. Some do more than others, but other than maybe Premiere they all have some media they just don't like. But it never hurts to send in the issue to Magix and see what they do with it.

Best Regards......George


Return to posts index

Michael Hoogasian
Re: Vegas Pro 16 absolutely CHUGS when working with MJPEG video
on Jun 19, 2019 at 3:13:45 pm

[Graham Bernard] "Supply MediaInfo of that MJPEG"

See my opening post ☺

[Graham Bernard] "Supply SCREENGRAB of your Project Settings."

See below



Return to posts index

Graham Bernard
Re: Vegas Pro 16 absolutely CHUGS when working with MJPEG video
on Jun 19, 2019 at 3:25:28 pm

[Michael Hoogasian] "See my opening post ☺"
My apologies.

OK, did you use the "Match" Icon?



You don't appear to have applied those settings?



* Grazie

Video Content Creator and Potter
PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX60HS Bridge


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]