ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

bug in outPoint output

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Yaniv Cahoua
bug in outPoint output
on Jun 17, 2019 at 7:56:50 am

Hey everyone,

I was getting a wrong outPoint value in my expression
A=thisComp.layer("Vibration Anim");
A.outPoint / thisComp.frameDuration;

As a test, I made a simple text layer and whip picked the A variable to a layer in my comp.
The inPoint will return the correct value but not the outpoint.


I had to play and move a bit the outPoint to get it to return the right value....
is this a known issue ?

http://www.yanivcahoua.com


Return to posts index

Miguel de Mendoza
Re: bug in outPoint output
on Jun 20, 2019 at 9:53:51 am

In the graphic interface of After Effects, you will always see "one more frame" at the end of the layer. If you look at the exact frame where the layer ends, you will see that nothing appears in the viewer. However, outPoint refers to that last frame in which the layer is no longer visible. Therefore, if you want to know what is the last visible frame of the layer, you should subtract a frame in your expression:

A=thisComp.layer("Vibration Anim");
A.outPoint / thisComp.frameDuration - 1;


Return to posts index

Yaniv Cahoua
Re: bug in outPoint output
on Jun 23, 2019 at 8:33:42 am

thank you
I am aware of that,
I was getting a big gap in value.
and it was clearly a bug when I played with the outpoint trimming it fixed it and I was getting accurate values

http://www.yanivcahoua.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]