ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

BUG Convert Expression to Keyframes After Effects CC

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Arturo Moreno Reyes
BUG Convert Expression to Keyframes After Effects CC
on Aug 31, 2017 at 2:53:34 pm

Hello, I've already ask that but probably my question wasn't that clear so I try to explain better.

I'm using a expression with "sampleImage" to do a color adjust by finding the black and the white point in the image with the effet "levels(individual controls)".
I pick the black and white point either in the first image of the shot, either at some marker. When I've made the right adjust I turn the expression to keyframes so I can copy the effect "Levels(individual controls)" to others shots froms the same camera.

Usually with CS6 and CC2014 turn expressions to keyframes was quite stable, but with the new versions CC2015 or CC2017 it changes all the values.





As you can see the result of the turn espression to keyframes is compltely different from the expressions results.

I've noticed that when the process is running, some of the properties briefly turn to light green (they're red when the expression is active, blue when there's no expression). The numbers change at that moment, and the wrong result actually is the same as the value when the propertie is light green.

If I try to do the turn expression to keyframes selecting just une propertie instead of the whole chunk it works well.

Well, hope this riddle is a little bit more clearer this time, and maybe that one of you will have a solution o turnaround.

Thank you !!

canal=0;
noir = effect("Noir")(1)/256;
blanc = effect("Blanc")(1)/256;
picker =effect("Point Noir Echantillon")(1);
e =Math.ceil(0.01+effect("Point Noir Etendue echantillon")(1));
marker.numKeys == 0 ? t=inPoint : t=marker.key(1).time;
thisLayer.sampleImage(picker,[e,e],false,t)[canal]-noir+value


Return to posts index

Kevin Camp
Re: BUG Convert Expression to Keyframes After Effects CC
on Aug 31, 2017 at 10:52:03 pm

i don't have an answer to the issue, but if you haven't already filed a bug report with adobe, here's the link:
http://www.adobe.com/products/wishform.html
you've done a good job documenting the issue, and i thin that will help them track down the bug.

you might also post in adobe's after effects forum, several of the programmers that work on after effects frequent that forum, and they may be able to give you a workaround or further insight in the issue until the bug is fixed.
https://forums.adobe.com/community/aftereffects_general_discussion

Kevin Camp
Art Director
KCPQ, KZJO & KRCW


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]