ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Expression and null object issue with message animation

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
ciarra crowe
Expression and null object issue with message animation
on Jul 21, 2017 at 8:47:45 pm

I watched this tutorial https://www.youtube.com/watch?v=qRMqCP153eA&t=310s to make a text message animation, starting at 20:00 she begins to create her null object.

My first 2 or 3 messages go up with the null object (they're all parented to it), but by the time I get to my 4th and 5th message they aren't following up onto the screen in a properly spaced out manner. It's as if my null object isn't moving up vertically enough to fit the rest of the messages under it.

I wanted to start my message sequence at the bottom of my composition, not in the middle, so is this my issue or am I supposed to adjust my message's position specifically on or off screen? Or should I just manually use keyframes to position my messages throughout the video?

Here's my expression:
move02=linear(thisComp.layer("Box02").transform.scale[0],0,100,transform.yPosition,transform.yPosition-thisComp.layer("Box02").content("Group 1").content("Rectangle 1").content("Rectangle Path 1").size[1]);
move03=linear(thisComp.layer("Box03").transform.scale[0],0,100,transform.yPosition,transform.yPosition-thisComp.layer("Box03").content("Group 1").content("Rectangle 1").content("Rectangle Path 1").size[1]);
move04=linear(thisComp.layer("Box04").transform.scale[0],0,100,transform.yPosition,transform.yPosition-thisComp.layer("Box04").content("Group 1").content("Rectangle 1").content("Rectangle Path 1").size[1]);
move05=linear(thisComp.layer("Box05").transform.scale[0],0,100,transform.yPosition,transform.yPosition-thisComp.layer("Box05").content("Group 1").content("Rectangle 1").content("Rectangle Path 1").size[1]);
move02+move03+move04+move05;

I'm still learning After Effects, so any help is appreciated.


Return to posts index

Scott McGee
Re: Expression and null object issue with message animation
on Jul 22, 2017 at 12:16:37 pm

The Expressions seem fine.

I assume you aren't getting any errors coming back.

Try manually moving the position of the boxes to where you want them. If you've added them after doing 1-3, I think that might be your issue. Parenting won't automatically put them in the correct place. You'll have to manually move them into the right location. All the null is doing it taking the height value to move all upwards.

Apologies if I've not understood your issue if I am completely wrong...But this is what I think might be your problem. I make this mistake alot when connecting properties to a null and forgetting that the null is going to move or is still moving and wondering why my properties don't match up.


Return to posts index

ciarra crowe
Re: Expression and null object issue with message animation
on Jul 23, 2017 at 8:20:34 pm

Thank you for the response! I'll try manually adjusting the boxes, but should I change the position under transform section or the Rectangle Path under contents?


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]