ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

i don't understand cache maybe

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Andy Engelkemier
i don't understand cache maybe
on Jun 21, 2017 at 2:03:08 pm

I'm not quite sure if this is an expression problem or not, but here goes:

I'm using a few effect, the main one being Write on, pointing to the world anchor point of a null layer (because it's parented so it's location would be wrong otherwise)

What I have is a dremel drilling into a surface. I'm using the writon effect to mask away that object, this is actually just a "sketch" animation so I'm just painting whit over the existing line, then I've added drop shadow to that with zero distance, and a simple choker on top of that so that it's basically just drawing a new line as it's cutting away. It works great, I thought it was a smart way of doing it.

So now the problem:

I'm rotating the hand, and moving it around to control the tip of the dremel. Sometimes I need to go back a little bit to make an adjustment. And just like that, the writeon doesn't update. A few frames later it catches up. Then where the writeon should have been the whole time suddenly snaps into place. But the problem is that doesn't update. If I scrub back, the incorrect frames are still incorrect. I can't get them to update. Aaaand as I thought about that I realized I should try purge all memory.
I closed AE, opened it again, and it's fine. So it seems like it's just trying to hold on to that.

This only seems to happen when I'm using that expression. Just to be clear, it's this one from Dan E:
L = thisComp.layer("Null 1");
L.toWorld(L.anchorPoint)


I have to look it up every time. Ugh. Luckily Dan has it posted up all over the place for people.

So any idea how to avoid this issue? Or do I just have to keep on deleting cache. I've since installed Trapcode Particular, which is Much faster than WriteOn, so I might just use that. But I'm the only one who has it here, so I try and avoid using it whenever I can in case i have to hand off some work. I might try that to see if I still get the same issue.

If anyone has some insights I'd love to learn what's going on and how to avoid/fix it.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]