ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Strobing Object not coming through in subsequent nested compositions

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Jaeson Jrakman
Strobing Object not coming through in subsequent nested compositions
on Jun 17, 2017 at 3:51:12 am

Hello,

So I am working in After Effects CS6 on a Windows laptop.

I have a composition with an expression that has an object's opacity strobing back and forth between 50% and 100% every frame.

The expression I'm using is such:

loopOut(type = "cycle", numKeyframes = 0)

When I preview the animation in the original composition, it strobes just fine all the way through.

I then have that composition, inserted into a second composition. The strobing seems to work fine upon preview of this second composition.

I then have this second composition, inserted into a third composition. The strobing seems to work fine upon preview of this third composition.

I then have a this third composition, inserted into a fourth composition. It is at this point that the strobing no longer comes through. The object remains at 50% opacity, as though it doesn't have any expression attached to it at all.

Is there a limit to the number of compositions one can nest an expression into before it no longer comes through?

Thanks in advance for any help anyone can give.

loopOut(type = "cycle", numKeyframes = 0)


Return to posts index

Dan Ebberts
Re: Strobing Object not coming through in subsequent nested compositions
on Jun 17, 2017 at 6:02:09 am

Are all your comps the same frame rate? How far apart are the keyframes?

Dan



Return to posts index

Jaeson Jrakman
Re: Strobing Object not coming through in subsequent nested compositions
on Jun 17, 2017 at 8:31:40 am

Keyframes are only one frame apart.

The first two compositions are at 29.97

But the last two compositions are at 30.

Maybe that's the problem?


Return to posts index


Jaeson Jrakman
Re: Strobing Object not coming through in subsequent nested compositions
on Jun 17, 2017 at 8:39:48 am

Thanks for responding.

I've gone through and changed all my comps to 29.97 frame rate, and the problem still seems to persist.


Return to posts index

Jaeson Jrakman
Re: Strobing Object not coming through in subsequent nested compositions
on Jun 17, 2017 at 8:45:53 pm

I tried deleting the expression, and hand animating the object to strobe back and forth between 100 and 50% opacity, but the problem still persists.


Return to posts index

Dan Ebberts
Re: Strobing Object not coming through in subsequent nested compositions
on Jun 17, 2017 at 8:49:16 pm

No time remapping anywhere in the heirarchy?

Dan



Return to posts index


Jaeson Jrakman
Re: Strobing Object not coming through in subsequent nested compositions
on Jun 17, 2017 at 8:56:06 pm

Ha! That was it! One composition was time stretched to 50%.

It had been so long since I was in this file, that I've forgotten everything I've done in it.

Thanks for helping out and answering this one!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]