ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

inPoint + linear weirdnesss

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Chris Scalzo
inPoint + linear weirdnesss
on May 26, 2017 at 11:54:25 am
Last Edited By Chris Scalzo on May 26, 2017 at 12:09:14 pm

I am trying to do a simple linear move starting from inPoint over the duration of the layer. Worked perfectly on first layer I put it on but other layers are starting before their inPoint. Anyone help me understand why?

transition = 60; // transition time in frames
tSecs = transition / ( 1 / thisComp.frameDuration); // convert to seconds
linear(time, inPoint, inPoint + tSecs, 0, -200)


Return to posts index

Dan Ebberts
Re: inPoint + linear weirdnesss
on May 26, 2017 at 1:23:09 pm

It works for me. Which property are using this expression with?

Dan



Return to posts index

Chris Scalzo
Re: inPoint + linear weirdnesss
on May 26, 2017 at 1:27:04 pm

I wanted to keep it simple to trouble shoot, so it is just on a slider control. if I duplicate the layer it works fine. If I copy the slider control to new layer, it starts 2 seconds earlier than inpoint of that new layer.


Return to posts index


Chris Scalzo
Re: inPoint + linear weirdnesss
on May 26, 2017 at 2:53:26 pm

if I jsut read the value that inPoint provides, it is off by 2 seconds from the start of that layer. The layer is a precomp and I am sure it is some type of bug or something I am overlooking with the precomp. I will try on a new comp layer when I get some time, but thanks for your help as always to assure I am not crazy


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]