ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Problem referencing same-named properties

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Charles Brepsant
Problem referencing same-named properties
on Mar 29, 2017 at 2:39:56 pm

Hi all,

I have a problem when referencing a property of an effect - specifically the Motion Blur property of the Saber videocopilot effect.

I use layer("LAYER").effect("Motion Blur") as a way to reference the property, but the result does not react to the property.

I am pretty sure this is happening because the property Motion Blur exists multiple times in the effect, according to the following hierarchies:

- Distortion/Glow Distortion/Motion Blur
- Distortion/Core Distortion/Motion Blur
- Render Settings/Motion Blur/Motion Blur

But I cannot find a way to reference those different properties.

Is there a way to specify which property we want to select?

The same thing is happening when I try to reference the property in a script using the following line:

mysolid.property("Effects").property("Saber").property("Motion Blur").setValue(1)

I would be grateful if anyone can help on this.

Thanks in advance

Charles


Return to posts index

Dan Ebberts
Re: Problem referencing same-named properties
on Mar 29, 2017 at 4:10:53 pm

I would use the Match name, like this for Glow Distortion / Motion Blur:

.property("VIDEOCOPILOT LightSaber-0107")

If you don't have Jeff Almasol's fabulous rd_GimmePropPath.jsx script, get it.

Dan



Return to posts index

Charles Brepsant
Re: Problem referencing same-named properties
on Mar 31, 2017 at 1:21:06 pm

Yay, many thanks for the answer Dan!

I actually had the script but never knew.

All the best !


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]