ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

360/ Expression + Expression pick whip not working

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Valentijn Wisseborn
360/ Expression + Expression pick whip not working
on Mar 22, 2017 at 9:27:29 am

Hello,

im trying to make this really simple accent 'explosion', but the thing is
that i get an error when im trying to use the expression:
360/content("Repeater 1").copies

I am probably a huge retard, but i honestly do not know why it isnt working

error log:

Expression disabled. Error at line 0 in property 'position of layer 1 ('Shape layer 1') in comp 'Intro'
Expression result must be of dimension 2, not 1.


Thanks for helping me out =]

360/content("Repeater 1").copies


Return to posts index

Dan Ebberts
Re: 360/ Expression + Expression pick whip not working
on Mar 22, 2017 at 5:33:09 pm

It looks like applied the expression to a Position property, which is expecting a array, like [x,y] and you've supplied a single number. What's the effect you're going for? You could do something like this:

{360/content("Repeater 1").copies,value[1]]

but that will only affect the x axis.

Dan



Return to posts index

Valentijn Wisseborn
Re: 360/ Expression + Expression pick whip not working
on Mar 23, 2017 at 9:35:40 am

I am trying to set the copies from the repeater in a circle,
you need to know that I have been After effects for around a week now;
and i've learned doing this in a tutorial, at least: it isnt working


it might help providing a link to the video:







trying to make something like that

btw: thanks for helping me out =]


Return to posts index


Valentijn Wisseborn
Re: 360/ Expression + Expression pick whip not working
on Mar 23, 2017 at 9:38:40 am

The expression at 5:45






Return to posts index

Dan Ebberts
Re: 360/ Expression + Expression pick whip not working
on Mar 23, 2017 at 11:18:19 am

The tutorial shows the expression being applied to the Rotation property, which is a 1D property, which should work fine with that expression.

The error message you posted indicates that you applied the expression to the Position property, which is expecting a 2D value, so that expression won't work there.

Dan



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]