ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Syntax error where there none?

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
David Cabestany
Syntax error where there none?
on Feb 15, 2017 at 10:44:18 pm

I'm revising a bunch of expressions to change the duration of a comp from 5 seconds to 10.
I have a slider control named "5 sec loop" I duplicated it and changed the name to "10 sec loop", then I used pt_ExpressEdit to change all the expressions at once.

All of them were disabled, however if I use the pickwhip to relink the property to the new slider it works ok, the text is exactly the same except for the 10 second bit, when I drag the pickwhip nothing changes in the selected text but the expression is enabled again.

It's not a huge deal as I can manually update all my expressions, but it sort of defeats the purpose of a script like pt_ExpressEdit

The offending expression is shown below.

Any ideas?

L=thisComp.layer("xp").effect(“10 sec loop")("Slider")
time*L;


Return to posts index

Dan Ebberts
Re: Syntax error where there none?
on Feb 15, 2017 at 10:53:07 pm

The first line has a curly quote on the left side of 10 sec loop.


Dan



Return to posts index

David Cabestany
Re: Syntax error where there none?
on Feb 15, 2017 at 11:04:08 pm

Thanks Dan,

Unfortunately that does not solve the issue. I just made a test to check for that.
The ExpressEdit script changes the quote marks automatically even if I do not touch them, I entered 5 sec loop without quotes and set it to replace it for 10 sec loop, also without the quote marks.

The quotes right next to the number changed automatically to the curly ones and all the expressions were disabled, however when I went and changed the quotes back to plain ones the expressions remained disabled, even after I manually changed the quote marks back to plain.



Best,
D.

L=thisComp.layer("xp").effect("10 sec loop")("Slider");
time*L;


Return to posts index


Dan Ebberts
Re: Syntax error where there none?
on Feb 15, 2017 at 11:19:52 pm

What's the error message when you click on one of the little warning signs next to the expression?

Dan



Return to posts index

David Cabestany
Re: Syntax error where there none?
on Feb 15, 2017 at 11:41:39 pm

Syntax error.

That's all it says.

Best,
D.


Return to posts index

Dan Ebberts
Re: Syntax error where there none?
on Feb 16, 2017 at 12:06:51 am

I don't know. I just pasted your expression into AE and I don't get any errors. Strange.

Dan



Return to posts index


David Cabestany
Re: Syntax error where there none?
on Feb 16, 2017 at 12:30:45 am

Yes, very weird. I ended up replacing the curly quotation marks with pain ones manually.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]