ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Error when pick-whipping properties across comps: "After Effects warning: layer named '...' is missing or does not exist. It may have been renamed, moved, or deleted, or the name may have been mistyped. A property expression referencing it

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Michael Lansdell
Error when pick-whipping properties across comps: "After Effects warning: layer named '...' is missing or does not exist. It may have been renamed, moved, or deleted, or the name may have been mistyped. A property expression referencing it
on Jun 16, 2016 at 11:26:49 am

I'm picking whipping some properties of a few layers across comps, so I can have a pre-comp update to match my main comp so I can use it as an obscuration layer for filters to reference. Not that should be relevant but I want a layer in Element 3D to be able to block a lens flare from Optical Flares.

When I do it I get this error:

"After Effects warning: layer named '...' is missing or does not exist. It may have been renamed, moved, or deleted, or the name may have been mistyped. A property expression referencing it was disabled."

(see attached for full info)



In my pre-comp I have a camera, a null and an Element 3D layer. The camera layer let me pick-whip the different variables across the two comps fine, but the null won't let me do any! Any come across this?

I'm using AE CC 2014 on OS X 10.10.2. If you need any more info please let me know, thanks!

comp("Earth").layer("Camera Control").transform.position


Return to posts index

Michael Lansdell
Re: Error when pick-whipping properties across comps: "After Effects warning: layer named '...' is missing or does not exist. It may have been renamed, moved, or deleted, or the name may have been mistyped. A property expression referencing
on Jun 16, 2016 at 11:31:06 am

It also won't pick-whip the Element 3D variables. Probably should have mentioned that!

I made the pre-comp by duplicating the main comp, if that might have any impact?


Return to posts index

Kalle Kannisto
Re: Error when pick-whipping properties across comps: "After Effects warning: layer named '...' is missing or does not exist. It may have been renamed, moved, or deleted, or the name may have been mistyped. A property expression referencing
on Jun 16, 2016 at 2:42:05 pm

I can't reproduce the problem. Can you upload a screen shot of your setup (the comp timelines) and what you're trying to link to what when this occurs?


Return to posts index


Dan Ebberts
Re: Error when pick-whipping properties across comps: "After Effects warning: layer named '...' is missing or does not exist. It may have been renamed, moved, or deleted, or the name may have been mistyped. A property expression referencing
on Jun 16, 2016 at 4:47:14 pm

Is it possible you have more than one comp named "Earth"? If so, the expression may be probably finding the wrong one in the project bin.

Dan



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]