ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Expression Disabled after Expression pick whip

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Tabea Bühlmann
Expression Disabled after Expression pick whip
on Jan 22, 2016 at 10:28:28 am

Hi all,
I'm using the after effects CC2015.
I have two different compositions
comp('PRODUCT_A_D') and comp('PRODUCT_A_F')
with the same photoshop file ('Product_A_psd')inside.

Now I want the file in comp('PRODUCT_A_F') to have the same position as in comp('PRODUCT_A_D'). I did it with the expressoion pick whip tool as I did it for years. In comp('PRODUCT_A_F') I pressed alt and klickt on the clock and the pick whip tool and put it on to the position clock of the file in comp('PRODUCT_A_D').

But it's not working and this error is popping up:

After Effects warning: Expression Disabled. Error at line 1 in property 'Position' of layer 14 ('Product_A.psd') in comp 'PRODUCT_A_F'.
layer named 'PRODUCT_A' is missing or does not exist. It may have been renamed, moved, or deleted, or the name may have been mistyped.

Now I really don't get it. The psd file is not not missing, nor is it moved or deleted and I also didn't renamed it and I didn't even typed beause I use the tool...

Can somebody pleas help me?

comp('PRODUCT_A_D').layer('PRODUCT_A').transform.position


Return to posts index

Xavier Gomez
Re: Expression Disabled after Expression pick whip
on Jan 22, 2016 at 6:01:55 pm

Have you renamed something after that ?

It is kind of weird that your expression uses single quotes, as normally AE uses double ones.

One thing to know is that AE recognises single quotes, but, when renaming layers/properties, comps etc, the expression engine only converts expressions that use double quotes.


Return to posts index

Dannel Flaveny
Re: Expression Disabled after Expression pick whip
on Jan 25, 2016 at 4:57:50 pm

hi all

i keep getting more less the same error message. Im working on a project that requires tracking but i keep getting this. any help will be greatly appreciated.


error at line 0 in property; position' of layer 1('Zion') in comp 'Comp 1'.
object of type layer found where Number,Array or property is needed

306572u57865271833725272


Return to posts index


Christopher Vranos
Re: Expression Disabled after Expression pick whip
on Jul 12, 2017 at 5:54:46 pm

Just solved this. You probably have two comps named the same, and the expression is looking into the comp that doesn't have your layer. Just rename all of your comps which are linked by expression so no two have the same name. Worked for me... Also make sure none of the layers are named the same either.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]