ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Evolution Stopped Evolving?

COW Forums : Adobe After Effects Expressions

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Tony Peterson
Evolution Stopped Evolving?
on Mar 20, 2009 at 5:57:27 pm

I have a 5min countdown clock with a fractal noise layer using the time*200 expression in the evolution. The evolution starts great and simply stops at 2:16... what the heck?
see it here...
http://www.vimeo.com/3778976
a rundown of my setup...
top layor: black solid with feathered mask (vingette)
next layor: text layor with the following expression (thank creative cow)
rate = -1;
clockStart = 300;
function padZero(n){
if (n < 10) return "0" + n else return "" + n
}
clockTime = Math.max(clockStart + rate*(time - inPoint),0);
t = Math.floor(clockTime);
min = Math.floor((t%3600)/60);
sec = Math.floor(t%60);
min + ":" + padZero(sec)

next layor: a png of the shiney logo
next layor: a psd of the textured dark ribbon
next layor: a black solid with the following effects (in order)
-Fractal Noise: this has the evo expression time*200
-Fast Blur: 15
-CC Vector Blur: 20
(this layors tranfer mode is set to Classic Color Dodge)
final layor: psd layor of a colorful graphic I made

thinking it had something to do with the time expression, i manually set a keyframe at the beginning of 0 evolution and at the end of 166x and it still stops at 2:16.
I'm stuck... please any ideas?


Return to posts index

Dan Ebberts
Re: Evolution Stopped Evolving?
on Mar 20, 2009 at 7:14:42 pm

I can't duplicate the behavior using your time expression. It works fine for me. There must be something else going on.


Dan



Return to posts index

Tony Peterson
Re: Evolution Stopped Evolving?
on Mar 20, 2009 at 7:20:21 pm

isn't that typical...
your car doesn't start so you call your car buddy over to take a look. pop the hood and turn the key and the car comes to a roaring start... that's life i guess.
thanks for trying, i suppose i'll just make the countdown 2:45min instead of 5min.



Return to posts index


Filip Vandueren
Re: Evolution Stopped Evolving?
on Mar 20, 2009 at 9:32:13 pm

My Evolution only works between about -90x 0° and 91x 0° which Corresponds with your problem.

It has to do with the maximum allowed value for integers inside After Effects, and I think they are different for mac and PC. Sad that the value isn't limited in the UI ie. that you couldn't scrub the value above that value like you can't set opacity to 101%

So:
In the evolution options, enable 'Cycle Evolution' and set Cycle (in Revolutions to a fairly high number that's less than this limit, let's say 80 in my case)

then use this in your expression:

rev=360 * effect("Fractal Noise")("Cycle (in Revolutions)");
t= (time*200)%rev;




Return to posts index

Tony Peterson
Re: Evolution Stopped Evolving?
on Mar 20, 2009 at 11:15:56 pm

Um...
fixed and FIXED!
I'm all up and running now... thanks a ton Filip!



Return to posts index

Chris Garcia
Re: Evolution Stopped Evolving?
on Oct 26, 2013 at 7:39:52 pm

Thanks Filip! I was stuck as well.


Return to posts index


Javier Toledo
Re: Evolution Stopped Evolving?
on Oct 5, 2018 at 4:43:20 pm

Great thank you very much! I had the same problem
It does not work for "turbulent noise" but it does work fine for "Fractal Noise".


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]