ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Illustrator File Loading Oddly in After Effects

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Erin Drewe
Illustrator File Loading Oddly in After Effects
on Feb 17, 2011 at 4:48:02 pm

Hello there! I've loaded an illustrator file (ai format) into After Effects as a composition, so I could maintain the layers from illustrator. I've worked on the illustrator comp within After Effects, with no problems, however, when I've closed AE and re-opened the AE project file, for some reason the illustrator layers are not loading their images up in my comp viewer panel. The odd thing is that if I scrub through the illustrator comp the vector art will flash visible for a moment, but disappear once I stop scrubbing. The other odd thing is that if I change the view quality from anything but full, the vector art suddenly reappears. Unfortunately the work I'm doing requires that I check how the vector art is interacting with other footage in full quality.

I'm not rasterizing the illustrator layers (doesn't seem to affect my "disappearing" problem from what I can tell), and I have figured out a work around to the "disappearing" illustrator comp by reloading the illustrator layers footage in my project window. However, re-loading the illustrator files is quite tedious every time I re-open after effects, so I was wondering, does anybody know if this is just a bug I've stumbled upon, or am I missing an option that should be checked off somewhere within After Effects that somehow stops my illustrator comp layers' viability from "disappearing?"

I'm using After Effects CS5 and Illustrator CS5. Again, I loaded the Illustrator file within AE as an ai format.

Thanks for any input!


Return to posts index

Dave LaRonde
Re: Illustrator File Loading Oddly in After Effects
on Feb 17, 2011 at 5:10:42 pm

[Erin Drewe] "...I'm using After Effects CS5 and Illustrator CS5...."

The answer to your problem might be found in this thread:
http://forums.creativecow.net/thread/2/995760

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Erin Drewe
Re: Illustrator File Loading Oddly in After Effects
on Feb 17, 2011 at 5:54:36 pm

Thanks for the suggestion. I gave the update a try, but it didn't change the problem.

It seems to be linked to the resolution setting I choose-- if I close AE with my footage at half res in the comp viewer, when I re-open AE it is only the half res that the illustrator images have "disappeared."

I'll have to try a test render and see if anything squirrelly is transferring over there too!


Return to posts index


Dave LaRonde
Re: Illustrator File Loading Oddly in After Effects
on Feb 17, 2011 at 8:48:59 pm

If the update doesn't fix it, all I have are shots in the dark, I'm afraid. But here they are, anyway.
  • Toggle the Live Update switch at the top of the timeline window, above the footage names.
  • Turn on the Continuously Rasterize switches; they look like little suns or asterisks.
  • Restore the default preferences: start AE, and hold down Ctrl-Alt-Shift (Win) or Cmd-Option-Shift (Mac) as it fires up.


Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Todd Kopriva
Re: Illustrator File Loading Oddly in After Effects
on Feb 17, 2011 at 9:21:55 pm

I know that this is going to seem like an irrelevant question, but it's not:

Do you have thumbnails on or off in the Project panel? You can change this with the Disable Thumbnails In Project Panel preference.

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
Technical Support for professional video software
After Effects Help & Support
Premiere Pro Help & Support
---------------------------------------------------------------------------------------------------------


Return to posts index

Erin Drewe
Re: Illustrator File Loading Oddly in After Effects
on Feb 18, 2011 at 1:17:58 am

I looked at the settings-- the "Disable Thumbnails in Project Panel" was not checked by me. On the first try I ticked it on out of curiosity to see what would happen, and my illustrator layers "disappeared" on my comp viewer panel instantaneously. I un-checked the Disable Thumbnails after that but nothing returned visible. I restarted AE after that, reloaded the Illustrator footage in my project panel, then played with the Disable Thumbnails and second time round it didn't seem to faze the illustrator files.

Hopefully that info is of some use!


Return to posts index


Eric Kliethermes
Re: Illustrator File Loading Oddly in After Effects
on May 11, 2011 at 6:40:10 pm

I had the same issue. I figured it out with a little investigation. Most likely you project is graphic heavy so you need to open up "Project settings" and change the Color Settings from 8bit to 32 bit Float. that should clear things up for you.


Return to posts index

Robert Paynter
Re: Illustrator File Loading Oddly in After Effects
on May 20, 2011 at 9:30:09 pm

I have the same issue. Reloading the assets work and sometimes changing the resolution does the trick.. but it is still a reoccurring annoyance. If there is a Fix let me know. Working in a 32bit doesn't really seem like a solution.


Return to posts index

Duncan York
Re: Illustrator File Loading Oddly in After Effects
on May 23, 2011 at 8:15:05 pm

Don't know if anyone has suggested this elsewhere or here - don't have time to read all the replies. But going to Edit->Purge->All solved this problem for me.


Return to posts index


Dana Vion
Re: Illustrator File Loading Oddly in After Effects
on Mar 30, 2012 at 3:39:00 pm

I had the same problem and going to EDIT>PURGE ALL solved it for me. Thanks Duncan!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]