ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Weird (user?) error with paths

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
bruno kochWeird (user?) error with paths
by on Feb 13, 2011 at 8:34:23 am

Hi!
I used a mask shape, which i pasted onto a null object's position. My problem is that when i duplicate one of the position keyframes on the null object to pause the movement it creates a weird loop.
http://users.atw.hu/brum/path.JPG
Can anyone explain why this happens and how can i bypass it?
Thanks in advance.


Return to posts index

Erik WaluskaRe: Weird (user?) error with paths
by on Feb 14, 2011 at 1:15:55 am

The link to your image was block by my spyware program. Could you post it directly on the Cow instead? (use the image upload button when you post)


Return to posts index

bruno kochRe: Weird (user?) error with paths
by on Feb 14, 2011 at 7:31:00 am

Ahh.. okay, there you go!
It's on the second picture, where i create another keyframe with the same position values. There should be no movement since the two keyframes are identical to each other, but it still creates a loop for some reason.


Return to posts index


Erik WaluskaRe: Weird (user?) error with paths
by on Feb 14, 2011 at 4:42:32 pm

OK, got it. The reason it's doing that is because you have bezier interpolation on the keyframes...


...which is fine, except they are in the same position so they are sort of folding in on themselves, creating that weird loop.


To understand what's happening, select the second keyframe and grab it with the selection tool in the comp window and move it to the right and watch the loop unfold...



You can fix it by breaking the handles and making the inner handles zero length, but if you're off just a little you'll get some movement or jittering between the keyframes so the best and the easiest way to fix it is to just make the first keyframe a hold keyframe...



To create a hold keyframe, either right-click and choose "toggle hold keyframe" or ctrl + alt + click the keyframe.

HTH


Return to posts index

bruno kochRe: Weird (user?) error with paths
by on Feb 14, 2011 at 4:44:26 pm

Ohhh.. Thank you very much! You were very helpful!


Return to posts index

Erik WaluskaRe: Weird (user?) error with paths
by on Feb 14, 2011 at 5:33:02 pm

No problem. Glad I could help.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]