ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

CC Particle World Not Passing In Front of 3D Objects

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Mike Edge
CC Particle World Not Passing In Front of 3D Objects
on Jan 30, 2011 at 2:08:57 am

I'm trying to create a comet that circles out from behind a planet and streaks toward the screen. I started by making the planet with CC Sphere and made the comet with CC Particle World and by following a Video Copilot tutorial (http://www.videocopilot.net/tutorials/3d_stroke_effect/).

The null and planet are both 3D layers. The null starts behind the planet and comes around one side and continues flying until it goes off screen. However, the comet streak will only ever be entirely behind or in front of the planet, rather than starting behind then crossing in front.

If I put in a camera then rotate around the comp, from certain angles everything will look proper, but from other angles will still look incorrect.

Original Comp Photo (No Camera): http://smg.photobucket.com/albums/v683/Riffamortis/?action=view¤t=Ori...

Angle 1 (Looks Correct): http://smg.photobucket.com/albums/v683/Riffamortis/?action=view¤t=Cam...

Angle 2 (Looks Correct): http://smg.photobucket.com/albums/v683/Riffamortis/?action=view¤t=Cam...

Angle 3 (Looks Incorrect): http://smg.photobucket.com/albums/v683/Riffamortis/?action=view¤t=Cam...

How can I fix this and make it look proper?


Return to posts index

Tudor "Ted" Jelescu
Re: CC Particle World Not Passing In Front of 3D Objects
on Jan 30, 2011 at 8:43:52 am

As far as I remember (been using Particular for most of my particle needs) CC Particle World and CC Sphere are meant to be applied to 2d layers. For Particular in order to interact with the 3d layers, the layer that has the plugin applied to it needs to be on top of all 3d layers- not sure if that is the same with CC Particle world.
One work around is to "sandwich" the planet (CC Sphere) layer in between two comet layers, cut a mask to reveal on the top layer the part of the comet that goes in front, copy the mask, paste it on the bottom layer and invert it.

Tudor "Ted" Jelescu
Senior VFX Artist


Return to posts index

Mike Edge
Re: CC Particle World Not Passing In Front of 3D Objects
on Jan 30, 2011 at 3:44:22 pm

Thanks for the response. I originally had the CC Sphere layer as a 2D layer but ran into this same problem, so I switched it to 3D in an attempt to see if it'd make a difference. I just tried moving the particle layer to the very top but with the same results. I guess it's masking time!

Thanks again,

Mike


Return to posts index


Brian Charles
Re: CC Particle World Not Passing In Front of 3D Objects
on Jan 30, 2011 at 4:23:21 pm

Actually there may be no need to mask, just split the particle layer at the point the particles move behind the planet. This may be old-school, but it can work in some circumstances.



Paricle Layer order





Return to posts index

Cassius Marques
Re: CC Particle World Not Passing In Front of 3D Objects
on Jan 31, 2011 at 1:44:27 pm

well since by his screen caps the particle is at the same time behind and in front of the planet I'm afraid Brian's approach won't work.

A better way I can think of, is to set your CC sphere layer to 3d (even though it is meant to be 2d) and put some expressions on it to make it respond to your camera.

As for the particles, I suggest you switching to trapcode particular - if you can - so you could use the visibility options within it. So you will have 2 particular layer, one above and on below your Sphere layer. And then set the far and near vanish parameters to match the distance from the planet to the camera.

Masking can do the trick too, but will make you very limited depending on your final goal.


Return to posts index

Jordan Quackenbush
Re: CC Particle World Not Passing In Front of 3D Objects
on Feb 8, 2011 at 10:55:10 pm

Here's a trick I did. And I registered for this forum solely because of this thread :) I spent probably an hour or two trying to figure this one out, searching CreativeCow and the recesses of Google, when I came up with a workaround myself.

I have a shield that was to have a star loop around it and reveal a part of the shield, as a camera rotated around the whole thing. An issue was that the shield was made in C4D, so I was working with a 2D QT. Behind the star were three instances of CC Particle World, following it. In order for the particles to be masked by the shield, I key'd the birthrate to go to 0 the frame the star went behind the shield, and then key'd back to my chosen birthrate when the star re-emerged. You'll have to adjust a bit if you have velocity and such so that the particles don't float "into" the area, but the trick seems to be the best I've found.

Cheers,
Jordan


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]