ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Xvid codec not appearing as an avi option

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
kristin robertshaw
Xvid codec not appearing as an avi option
on Dec 14, 2010 at 5:12:11 am

I have downloaded the same Xvid codecs that I used for After Effects CS4, 32-bit Windows XP, but now that I am running Windows 7, 64-bit, After Effects CS5, Xvid does not appear as an avi video codec option.

Any suggestions?


Return to posts index

Todd Kopriva
Re: Xvid codec not appearing as an avi option
on Dec 14, 2010 at 6:37:20 am

Codecs must be 64-bit to work with After Effects CS5.

---------------------------------------------------------------------------------------------------------
Todd Kopriva, Adobe Systems Incorporated
Technical Support for professional video software
After Effects Help & Support
Premiere Pro Help & Support
---------------------------------------------------------------------------------------------------------


Return to posts index

kristin robertshaw
Re: Xvid codec not appearing as an avi option
on Mar 8, 2011 at 6:49:17 pm

I have installed the 64 bit K-lite codec pack and still do not see these available codecs.


Return to posts index


Dave LaRonde
Re: Xvid codec not appearing as an avi option
on Mar 8, 2011 at 10:09:30 pm

Um, you might want to think about UNinstalling that K-Lite stuff. It gives AE fits like you wouldn't believe.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

kristin robertshaw
Re: Xvid codec not appearing as an avi option
on Mar 8, 2011 at 10:11:29 pm

Do you have any recommendations on 64 bit xvid and divx codecs?


Return to posts index

Dave LaRonde
Re: Xvid codec not appearing as an avi option
on Mar 8, 2011 at 11:25:57 pm

I'm afraid I have no recommendation; I never work with those codecs, and I'm sorry you have to.

The only thing I can suggest is to render lossless from AE, and use something else to do the encoding.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index


Thiago Lobo
Re: Xvid codec not appearing as an avi option
on Mar 19, 2011 at 8:02:34 pm

Ok, Dave,

I've seen your recomendations before and I totally agree with them. Rendering lossless in AE and encoding somewhere else (Adobe Media Encoder, Sorenson Squeeze, for example) is way better.

But now, in Adobe Media Encoder, the option to use DivX codec (AVI container) is missing. I'm on Windows 7 64-bit, what can I do to get this option available?


Return to posts index

John tolliver
Re: Xvid codec not appearing as an avi option
on Apr 13, 2011 at 5:26:02 pm

Ok, so there are clearly issues with xvid and CS5. I have found a solution that keeps the program from freezing up while rendering out a single pass AVI (we use them when rendering short static videos).

In the options for the xvid codec: There is a button for "other options", under the encoding tab, you must uncheck "Display Encoding Status" When that is unchecked, our AE renders fine.

John


Return to posts index

kristin robertshaw
Re: Xvid codec not appearing as an avi option
on Apr 13, 2011 at 8:55:02 pm

I am unable to see an xvid codec in the available list of video codecs for AVI options. See attached. Where did you obtain the xvid codec and how did you get AE to recognize it?


Return to posts index


kristin robertshaw
Re: Xvid codec not appearing as an avi option
on Apr 13, 2011 at 9:00:54 pm

Here is the image...



Return to posts index

Kent Yang
Re: Xvid codec not appearing as an avi option
on Oct 27, 2011 at 2:25:50 pm

Hey Guys,

I have the same problem with my CS5.5 64bit, so I asked the official XVid members, and here is their answer: (I haven't try it yet, but I'll do it tomorrow...)

Official Reply:

in recent versions of Xvid, there is no special 32-bit or 64-bit installer package anymore. So there's just one Xvid setup file for Windows that contains both the 32-bit and the 64-bit codec and automatically installs the right version. The latest Xvid installer (v1.3.2) can be found here:

http://downloads.xvid.org/downloads/Xvid-1.3.2-20110601.exe

Basically, it is not important whether you have Windows 64-bit or 32-bit.The real question is whether your After Effects program runs as 32-bit or64-bit process. That's because 32-bit applications can only communicatewith 32-bit codecs and 64-bit programs only with 64-bit codecs. So if yourAfter Effects is 64-bit, it will require also Xvid as 64-bit.

The above installer should install both 32-bit and 64-bit Xvid on your system. You can check if Xvid got properly installed and is correctly usable in both 32-bit and 64-bit by using a simple video editing application that is available in both 32-bit and 64-bit, like e.g. the excellent and free VirtualDub: http://www.virtualdub.org

If Xvid shows up in the codec list of both 32-bit and 64-bit VirtualDub, then the Xvid codec got properly installed...


Return to posts index

kristin robertshaw
Re: Xvid codec not appearing as an avi option
on Oct 27, 2011 at 7:07:04 pm

I installed and now I see the xVid option when rendering in Adobe Media Encoder. I'm still confused as to why I don't see it as an option in Adobe Premiere Pro, considering it's the same rendering engine. But THANK YOU!


Return to posts index


kristin robertshaw
Re: Xvid codec not appearing as an avi option
on Oct 27, 2011 at 7:10:40 pm

I take it back...just had to re-start Premiere.

Again, many thanks!


Return to posts index

Kent Yang
Re: Xvid codec not appearing as an avi option
on Oct 28, 2011 at 1:00:36 am

I tried it this morning. IT WORKS!!!! Yeah~~~~~

For those who still have trouble getting this option in your AE, you might have to reboot your computer after installing this codec. Besides, turn off the "Display Encoding Status"option under the XVid Codec Settings window, or your AE will freeze when it's rendering.

Good luck!!


Return to posts index

ilia labazde
Re: Xvid codec not appearing as an avi option
on Dec 14, 2011 at 3:18:55 pm

ook it kinda shows but.. when i choose xvid and click it's settings it does show up. but when i click ok my after effects freezes and crushes. only way to avoid crush is to not to enter settings menu; just choose xvid and start rendering. but here another problem arises:
when i try to export video with sound 44 bir or 48 or any. rendering crushes at start. and AE closes. however if ill try to render without sound it does render.

Mac Pro Windows 64x Adobe master collection CS5; After effects.
(also i have same picture as posted above; no codecs, just one xvid.)


Return to posts index


ajay kumar
Re: Xvid codec not appearing as an avi option
on Nov 4, 2012 at 1:03:38 pm

Thank you Kent Yang I followed your post step by step , finally I render successfully


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]