ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

CS5- rendering without Timecode Track

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Rich RamazinskiCS5- rendering without Timecode Track
by on Nov 23, 2010 at 7:22:37 pm

Hey kids!

I'm working at a studio that has recently switched from AE CS4 to CS5. I've noticed in CS5 that all my Quicktime renders have a Timecode Track embedded in them. I'm not talking about burned into the image; I'm talking about the file having an Audio track, a Video track, and a Timecode track.

Due to the way some proprietary in-house programs work here, this timecode creates lots of waves and angry programmers/editors down the pipeline. I know i can easily delete it in Quicktime Pro, but want to not have to add an extra step for hundreds of renders.

Anybody know what setting can be changed to turn off Timecode Track rendering?

thanks a bunch

r

http://www.richrama.com


Return to posts index

Dave LaRondeRe: CS5- rendering without Timecode Track
by on Nov 23, 2010 at 7:45:53 pm

Although it's not a concern of mine at this time, AE 10 has the ability to work with and preserve a LOT more metadata than it could previously. This could be the source of your colleagues' frustration.

The following might be worth a quick look-see:
http://help.adobe.com/en_US/aftereffects/cs/using/WSE208DA8E-DC73-4567-8B88...

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Rich RamazinskiRe: CS5- rendering without Timecode Track
by on Nov 23, 2010 at 8:21:21 pm

thanks for the response, Dave!

hmmm. I thought making sure I kept "Include Source XMP Metadata" unchecked would keep all metadata from being added to my files. After I do this the Timecode Track is still there however.

If anybody is wondering, my source footage has no Timecode info, and my final outputs are currently QT Photo-Jpeg, and .mp4. CS5 is updated to 10.0.1.19, on Win7 64bit.

Still searching for answers...

http://www.richrama.com


Return to posts index


Walter SoykaRe: CS5- rendering without Timecode Track
by on Nov 23, 2010 at 8:32:04 pm

Rich, this isn't a direct answer to your question, but you can use Bouke Vahl's qtChange application to batch-remove timecode tracks from Quicktime movies.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Rich RamazinskiRe: CS5- rendering without Timecode Track
by on Nov 23, 2010 at 9:55:14 pm

thanks for the link, Walt!

that could be useful.

Still sniffin around the Metadata Window, figuring out how AE's metadata workflow operates.

r

http://www.richrama.com


Return to posts index

Josh KirschenbaumRe: CS5- rendering without Timecode Track
by on Jan 7, 2011 at 8:55:26 pm

It seems like this topic has faded away a bit...but I'm having a similar issue - and ANY help would be greatly appreciated.

My 23.976 ProRes 422 renders out of After Effects CS5 seem to have 29.97 Timecode tracks embedded in them. When bringing these into Final Cut Pro, they do not playback correctly - since there is this discrepancy. When I delete the Timecode track with Quicktime Player, they seem to be fine now.

The Metadata panel in AE CS5 indicates that the ORIGINAL footage has an Alternate Timecode Time Format of "23976Timecode". When I bring my RENDER back into AE CS5, the Metadata panel indicates that it has a Alternate Timecode Time Format of "2997Timecode".

I can find NO place in After Effects where I can alter this - it seems like there is a default XMP Metadata flag set somewhere, but I don't know where.

I'm working with 23.976 ProRes 422 footage, importing into AE CS5, creating a 23.976 comp, and then rendering back to a ProRes 422 23.976 quicktime.

Any help would be GREATLY appreciated.

Thanks.
vfxjokir@gmail.com



Return to posts index


Walter SoykaRe: CS5- rendering without Timecode Track
by on Jan 7, 2011 at 9:05:28 pm

[Josh Kirschenbaum] "My 23.976 ProRes 422 renders out of After Effects CS5 seem to have 29.97 Timecode tracks embedded in them. When bringing these into Final Cut Pro, they do not playback correctly - since there is this discrepancy. When I delete the Timecode track with Quicktime Player, they seem to be fine now."

This seems to be a bug in After Effects. See my post in another thread here [link].

To work around this, select your incorrect clip in FCP's browser, then click Modify > Timecode... Change the rate to 24. When you click OK, FCP will replace the timecode track in the original Quicktime media on disk. This is one of the few operations in Final Cut that actually alters the source media.

I'd also ask that you please join in my bug-report crusade on this -- thank you!

https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Josh WeissRe: CS5- rendering without Timecode Track
by on Apr 26, 2011 at 7:36:18 pm

Walter, unfortunately this doesn't solve the problem. If you adjusted your start time in AE, to say 05:15:07:00, your new timecode in FCP for your start time will be probably a good hour off, so even if you change to 24 for your TC base, the timing won't line up. I have a friend who got his hands on a copy of CS 5.5, same problem. So I had him do a test in premiere and everything works just fine. Its some tag that AE is reading that no other program reads. Even tried in the AJA utilities and they see it the same as FCP.



Return to posts index

Walter SoykaRe: CS5- rendering without Timecode Track
by on Apr 27, 2011 at 3:45:19 am

Josh, am I misunderstanding something here? I just tested this workaround with your suggested timecode and it works fine. Where are we getting different results?

I rendered out a 720p23.976 file from AE, with a comp starting timecode of 05:15:07:00. The file from AE came into FCP correctly at "23.98" fps, and started at 05:15:07:00, but had a timebase of 30 (so stepping through a frame at a time causes the timecode to jump: :00, :01, :02, :04, :05, :06, :07, :09, etc.).

In FCP, Modify > Timecode, choose to set first frame, confirm that the timecode is 05:15:07:00, and change the "Rate" column to 24, and click Ok. This will overwrite the TC track in the file with the correct timecode. Stepping through frame-by-frame in FCP now gives the expected results.

I can confirm that PPro always reports the expected timecode, regardless of what QT-based apps report.

It's disappointing to hear this wasn't address with all the timecode goodness in CS5.5.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index


Josh WeissRe: CS5- rendering without Timecode Track
by on Apr 27, 2011 at 5:56:11 pm

Walter,

I went back and did some tests today. I had my friend do the CS5.5 tests as well. Here is what I found, you are correct with CS5. If you manually enter a timecode in AE, it will come back to FCP. The reason I had abandoned the hope of doing that, was because I was modifying to 24 base setting in FCP under item properties. When you do that, it changes your timecode (try it with a clip in the middle of a second, for instance it would probably change frame 15 in what it thinks is a 30 base to 12 in a 24 base). Doing it in the modify menu as you suggest does work, but you have to manually reenter your start time when FCP screwes it up as described above.

With CS5.5 however, it just totally screws it up.



As you can see above, the top clip is the original.
The middle, and totally wrong clip is CS5.5 (though the timecode was right in AE and right in premiere).
The bottom clip was rendered in CS5, but i didn't change it to 24 base yet so the timecode is still right.

What this shows is unfortunately not only has the 24 problem not been fixed, BUT the timecode is doesn't even come through at all!



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]