ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Unmotivated Opacity Jumps in Trapcode Particular 2

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Zak Stoltz
Unmotivated Opacity Jumps in Trapcode Particular 2
on Nov 17, 2010 at 9:52:25 pm

Hey everyone, I originally posted this in the Trapcode forum a while back, but nobody has responded... So I was hoping maybe someone here could help.

So here's the situation. I have a "static" particle field consisting of a bunch of icon sprites floating in space. All of them are set to 100% opacity, but for some reason, regardless of how close or how far they are from the camera (which is pushing in slowly), SOME of them look like they're at about 80-90% opacity.

Then, to make matters worse, they randomly jump up to 100% opacity over the course of the camera pushing in.

I have no idea what could be causing this, and I've played around with a ton of settings (e.g., near fade, far fade, opacity over life, and everything else that looked like it could be making a difference).

Does anyone have any idea at all what could be causing this?

Thank you!

Zak


Return to posts index

Kevin Camp
Re: Unmotivated Opacity Jumps in Trapcode Particular 2
on Nov 17, 2010 at 10:20:27 pm

if you are seeing this in preview, do you have opengl disabled in preferences>previews? i'm not positive if particular uses opengl to speed up previews, but it seems like it might... and opengl is notorious for ufo's (unexplainalbe-freaking-'o'nomalies).

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

Zak Stoltz
Re: Unmotivated Opacity Jumps in Trapcode Particular 2
on Nov 17, 2010 at 11:12:34 pm

It's showing up in both the preview and the render. I can actually go frame by frame and see where the opacity jumps up to 100% in my timeline. If I change the random seed of the arrangement of particles, it still happens, but to different sprites.

It's very bizarre because nothing should be appearing at less than 100% opacity anyway... I'm stumped.


Return to posts index


Kevin Camp
Re: Unmotivated Opacity Jumps in Trapcode Particular 2
on Nov 17, 2010 at 11:50:24 pm

it may very well be a problem within the plugin. you should double check that you have the latest version.

you might be able to fix it post render, or at least make it less noticeable with frame blending, or a time effect like cc widetime or cc time blend. or even masking out 'bad' particles depending on if the overlap may other particles.

Kevin Camp
Senior Designer
KCPQ, KMYQ & KRCW


Return to posts index

Zak Stoltz
Re: Unmotivated Opacity Jumps in Trapcode Particular 2
on Nov 18, 2010 at 6:03:45 am

Hmm, I will definitely check to see if I have the latest version of the plugin.

There are so many particles all over the place that are doing it that masking isn't really a practical option. I'm not familiar with the time effects you mentioned, but I looks like I'm about to familiarize myself. :-)

Thanks for the responses! I really appreciate your suggestions.

Anyone else experienced something similar or have an idea of what might be at the root of this problem?


Return to posts index

Michael Szalapski
Re: Unmotivated Opacity Jumps in Trapcode Particular 2
on Nov 18, 2010 at 5:46:04 pm

Any chance we could have a gander at the project file to see if it's your computer or the project itself that has the issue?

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index


Zak Stoltz
Re: Unmotivated Opacity Jumps in Trapcode Particular 2
on Nov 19, 2010 at 12:47:33 am

EXCELLENT NEWS! I've solved the mystery of the semi-transparent icons.

Motion blur. Yes, motion blur. I had pre-comped the Particular layer with its camera, and the motion blur switch was checked for the Particular layer. When I turned off motion blur on that layer, and that layer only, everything was 100% opaque, just as it was supposed to be.

When I discovered this laughably simple solution, I was worried that I wouldn't be able to have any motion blur on my particles at all. I didn't mind that for the pre-comp because it was supposed to be a relatively static field with the camera moving through it. Little to no visible motion blur anyway. However, the whole particle system is subjected to some pretty gnarly motion in the context of the whole project. Luckily, that motion blur remains unaffected, and I still retain my desired results. Hooray!

I still have to do a final render at full res before I know for 100% sure that everything is OK, but I'm confident that my test results are indicative of a case closed. If you don't hear from me tomorrow, it's safe to assume everything worked out.

Thanks everyone!

Zak


Return to posts index

Michael Szalapski
Re: Unmotivated Opacity Jumps in Trapcode Particular 2
on Nov 19, 2010 at 2:09:43 pm

Glad to hear it.

- The Great Szalam
(The 'Great' stands for 'Not So Great, in fact, Extremely Humble')

No trees were harmed in the creation of this message, but several thousand electrons were mildly inconvenienced.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]