ADOBE AFTER EFFECTS: Forum Expressions Tutorials Creative Cloud

Disabling multiprocessing for RAM previews

COW Forums : Adobe After Effects

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Jared Flynn
Disabling multiprocessing for RAM previews
on Nov 17, 2010 at 4:09:52 pm

Hi all,

Is there a way to rig AE such that multiprocessing is enabled for rendering, but not for RAM previews? I have a large project that takes forever to save, and as such RAM previewing takes forever to start caching frames. I sometimes disable multiprocessing to fix that, but then I'll forget to turn it back on when I go to render my scene overnight. Next thing I know I wake up the next morning and my render's still not done, because multiprocessing is off.

I've dug through all the preferences and I can't seem to find a way to specify such a thing, but I really hope it exists because it's awfully irritating to wait upwards of two minutes for a RAM preview just to get going!

Thanks,

Jared Flynn
Motion Graphics Designer / Lead AE
Lone Wolf Documentary Group


Return to posts index

Walter Soyka
Re: Disabling multiprocessing for RAM previews
on Nov 17, 2010 at 4:13:34 pm

With regard to the RAM preview delay -- what version of AE are you using? Have you installed the latest updates for your version?

If you need to keep multiprocessing off for your RAM previews, you could can use Lloyd Alvarez's BG Render script for all your rendering. It has an option to use multiprocessing which is independent of AE's setting.

Walter Soyka
Principal & Designer at Keen Live
Motion Graphics, Widescreen Events, Presentation Design, and Consulting
RenderBreak Blog - What I'm thinking when my workstation's thinking
Creative Cow Forum Host: Live & Stage Events


Return to posts index

Dave LaRonde
Re: Disabling multiprocessing for RAM previews
on Nov 17, 2010 at 4:17:07 pm

[Jared Flynn] "Is there a way to rig AE such that multiprocessing is enabled for rendering, but not for RAM previews?"

There may be a script to do this, but I don't know about it. There isn't any handy way to do it in AE straight out of the box; you have to set it in Preferences.



[Jared Flynn] "I have a large project that takes forever to save, and as such RAM previewing takes forever to start caching frames."

This sounds like a case of insufficient RAM, and it leads to a set of questions: what AE version are you running, how much RAM do you have, and what are your machine's processors/cores and OS?

You may just have memory allocations out of whack in AE, but we won't know without details.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index


Jared Flynn
Re: Disabling multiprocessing for RAM previews
on Nov 17, 2010 at 4:47:51 pm

Hi there Dave,

I think the culprit is that my project makes heavy use of both CS5's Roto Brush and Foundry's CameraTracker plugin, both of which I've found to be massive performance killers (I presume because of all the keyframes they generate). My other projects that use those tools less or not at all tend to perform SIGNIFICANTLY better.

My specs shouldn't be the problem-- I run AE CS5 (10.0.1.19) on a Lenovo Thinkpad W701 with a 1.6Ghz hyperthreaded Core i7 proc (8 logical cores) and 16GB of very quick RAM, as well as a 1GB, 96-CUDA core nVidia Quadro FX 2800M. Windows 7 Professional 64bit.

That said, my multiprocessing settings might be less than optimal. I grabbed them from some advice I read on AE Portal News. A little more modest than my original settings (which essentially handed my entire system over to AE if it so chose):

Installed RAM: 15.9GB
RAM reserved for other applications: 6GB
Installed processor cores: 8
CPUs reserved for other applications: 4
RAM allocation per background CPU: 3GB
Actual CPUs that will be used: 2

It's too bad there doesn't seem to be a way to designate what gets the multiprocessing treatment... I can look into scripts, and boy howdy in the meantime I'll be filing a feature request!

Definitely let me know if my specs or settings raise any flags for you though; I'm always game to try some new configs in the interest of squeezing a bit more excellence out of my kit!

Thanks in advance,

Jared Flynn
Motion Graphics Designer / Lead AE
Lone Wolf Documentary Group


Return to posts index

Dave LaRonde
Re: Disabling multiprocessing for RAM previews
on Nov 17, 2010 at 5:21:26 pm

Optimum memory settings in AE 10 is something of a work in progress, because there is almost no such thing as two identical systems. Here are the latest recommendations:

http://blogs.adobe.com/toddkopriva/2010/10/please-try-recommended-memory-se...

It sort of a shame that you run on a laptop. AE 10 opened up a whole new world of RAM utilization because it's 64-bit. You can cram enough memory into a laptop to make AE sing, but you won't ever be able to hit the really high notes.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Jared Flynn
Re: Disabling multiprocessing for RAM previews
on Nov 17, 2010 at 5:26:04 pm

Thanks again Dave!

It's true, I definitely sacrifice some significant upgrade options running on a laptop (I'm pretty sure my RAM is maxed out at the moment, though I can jockey for a few proc upgrades from what I've currently got, as well as a twice-better Quadro if I ever have the money). For the moment it's really essential that I be extremely mobile with my work, and to that end I can definitely say this Thinkpad beats the pants off the other kits I researched hands down.

That said, rest assured I'm using what power I can muster from this wee beastie to save up for a killer desktop. :)

Jared Flynn
Motion Graphics Designer / Lead AE
Lone Wolf Documentary Group


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]